summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2015-05-13 23:01:46 +0200
committerNarrat2015-05-13 23:01:46 +0200
commit601e60b623db16e8eda5982a82c5744f9d41c0a9 (patch)
treebc503214be8dd7a313f90db954c87060f526dcea
downloadaur-601e60b623db16e8eda5982a82c5744f9d41c0a9.tar.gz
z600: Latest files
History: https://github.com/Narrat/PKGBuilds
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore14
-rw-r--r--PKGBUILD33
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c9eff126031e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = z600
+ pkgdesc = Lexmark Z600 Printer Driver
+ pkgver = 1.0
+ pkgrel = 3
+ url = http://www.lexmark.com/
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = rpmextract
+ makedepends = gzip
+ source = http://downloads.lexmark.com/downloads/cpd/CJLZ600LE-CUPS-1.0-1.TAR.gz
+ md5sums = c0e35c9819b25e587e75a5a743c49f18
+ depends_i686 = cups
+ depends_i686 = libstdc++5
+ depends_x86_64 = cups
+ depends_x86_64 = lib32-libcups
+ depends_x86_64 = lib32-libstdc++5
+
+pkgname = z600
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3a3642b6f6ff
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,14 @@
+*/src
+*/pkg
+*.gz
+*.xz
+*.bz2
+*.zip
+*.part
+*.sig
+*.sign
+*.txt
+*.log
+*.scm
+*/*.pkg
+*/*.asc
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bf2afc1be928
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Contributor: Peter Baldwin <bald_pete@hotmail.com>
+# Contributor (modifications): Bruno Tsubouchi Yporti <brunoyporti@gmail.com>
+# Contributor (modifications): Igor Nemilentsev <trezorg@gmail.com>
+# For Lexmark Z601, Lexmark Z602, Lexmark Z604, Lexmark Z605, Lexmark Z615, and Dell 720
+# Partial suport in others printers (e.g. Lexmark X1250)
+
+pkgname=z600
+pkgver=1.0
+pkgrel=3
+pkgdesc="Lexmark Z600 Printer Driver"
+arch=('i686' 'x86_64')
+url="http://www.lexmark.com/"
+license=('custom')
+makedepends=('rpmextract' 'gzip')
+depends_i686=('cups' 'libstdc++5')
+depends_x86_64=('cups' 'lib32-libcups' 'lib32-libstdc++5')
+source=("http://downloads.lexmark.com/downloads/cpd/CJLZ600LE-CUPS-1.0-1.TAR.gz")
+md5sums=('c0e35c9819b25e587e75a5a743c49f18')
+
+
+build() {
+ cd $srcdir
+ tar xf CJLZ600LE-CUPS-1.0-1.TAR.gz
+ tail -n +143 z600cups-1.0-1.gz.sh > install.tar.gz
+ tar xf install.tar.gz
+ rpmextract.sh z600llpddk-2.0-1.i386.rpm
+ rpmextract.sh z600cups-1.0-1.i386.rpm
+}
+
+package() {
+ cd $srcdir/
+ mv -f usr $pkgdir
+}