summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMariano Street2021-06-19 01:31:54 -0300
committerMariano Street2021-06-19 05:24:14 -0300
commit4027f019f21d4b255130fe1be77408aaecd56602 (patch)
tree2d75e815e6a8567555d25cd4ed3da60e1870762d
parent7468f4c10558774b55d4e8dcb5a5912d58201afd (diff)
downloadaur-4027f019f21d4b255130fe1be77408aaecd56602.tar.gz
Avoid build directory for better reproducibility
Using a build directory causes binaries to contain absolute build path strings.
-rw-r--r--PKGBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ff1deb3ae952..24b3220c0e8f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,8 +16,6 @@ sha256sums=(e81d9edf373f193af428a0f256674aea62a9d74dfe93f65192d4eae030b0f3b0
validpgpkeys=(3A24BC1E8FB409FA9F14371813FCEF89DD9E3C4F) # Nick Clifton <nickc@redhat.com>
prepare() {
- mkdir -p binutils-build
-
cd binutils-$pkgver
# Turn off development mode (-Werror, gas run-time checks, date in sonames)
@@ -28,9 +26,9 @@ prepare() {
}
build() {
- cd binutils-build
+ cd binutils-$pkgver
- "$srcdir/binutils-$pkgver/configure" \
+ ./configure \
--target=$_target \
--with-sysroot=/usr/$_target \
--prefix=/usr \
@@ -46,7 +44,7 @@ build() {
}
check() {
- cd binutils-build
+ cd binutils-$pkgver
# unset LDFLAGS as testsuite makes assumptions about which ones are active
# do not abort on errors - manually check log files
@@ -54,7 +52,7 @@ check() {
}
package() {
- cd binutils-build
+ cd binutils-$pkgver
make DESTDIR="$pkgdir" install