summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntoine Viallon2021-02-08 10:27:27 +0100
committerAntoine Viallon2021-02-08 10:27:27 +0100
commitc78a81b1ef24a4f58fd36e62b8bb4e02e999f92e (patch)
tree396380e73297bf69e052f6921fe18c4a8b04fa2f
parentad242811cc7728bc347c3381e0b471a8e6c353e8 (diff)
downloadaur-z80e.tar.gz
Bump to 0.5.3 and remove now obsolete SDL workaround
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 24f8ecdc43a5..b79f2fc4da69 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = z80e
pkgdesc = An emulation library and client programs for z80 calculators
- pkgver = 0.5.0
+ pkgver = 0.5.3
pkgrel = 2
url = https://github.com/KnightOS/z80e
arch = x86_64
@@ -10,8 +10,8 @@ pkgbase = z80e
makedepends = asciidoc
depends = sdl
depends = scas
- source = z80e-0.5.0.tar.gz::https://github.com/KnightOS/z80e/archive/0.5.0.tar.gz
- md5sums = cec89fd0b0eecc63b616eabbe973ac4f
+ source = z80e-0.5.3.tar.gz::https://github.com/KnightOS/z80e/archive/0.5.3.tar.gz
+ md5sums = 871b1d66c749b409f82e8b58c1c5334b
pkgname = z80e
diff --git a/PKGBUILD b/PKGBUILD
index 9746c49fefd3..7204e69eee49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=z80e
-pkgver=0.5.0
+pkgver=0.5.3
pkgrel=2
license=('MIT')
pkgdesc='An emulation library and client programs for z80 calculators'
@@ -10,11 +10,11 @@ makedepends=("cmake" "asciidoc")
arch=("x86_64")
url='https://github.com/KnightOS/z80e'
source=("$pkgname-$pkgver.tar.gz::https://github.com/KnightOS/z80e/archive/$pkgver.tar.gz")
-md5sums=('cec89fd0b0eecc63b616eabbe973ac4f')
+md5sums=('871b1d66c749b409f82e8b58c1c5334b')
build() {
cd "${pkgname}-${pkgver}"
- echo "TARGET_LINK_LIBRARIES(z80e-sdl SDL2)" >> frontends/sdl/CMakeLists.txt
+ #echo "TARGET_LINK_LIBRARIES(z80e-sdl SDL2)" >> frontends/sdl/CMakeLists.txt
cmake -Denable-sdl=YES -DCMAKE_INSTALL_PREFIX=/usr .
make
}