summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntoine Viallon2020-06-20 11:51:24 +0200
committerAntoine Viallon2020-06-20 11:51:24 +0200
commit2fc0c2d363cf5e2df8e5d7317e854457ad22f56a (patch)
tree77d42d92eaf849447c7be4620b6195d4c3979db6
parent6020dfa7fbe8ed4f3bbe036f961e58b551888023 (diff)
downloadaur-2fc0c2d363cf5e2df8e5d7317e854457ad22f56a.tar.gz
Update to 0.5.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD5
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bc21f3f10ee2..9d86a55eabd6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = z80e
pkgdesc = An emulation library and client programs for z80 calculators
- pkgver = 0.4.0
+ pkgver = 0.5.0
pkgrel = 1
url = https://github.com/KnightOS/z80e
arch = x86_64
@@ -9,8 +9,8 @@ pkgbase = z80e
makedepends = asciidoc
depends = sdl
depends = scas
- source = https://github.com/KnightOS/z80e/archive/0.4.0.tar.gz
- md5sums = cef93422186f55541be34aee0004bbb8
+ source = z80e-0.5.0.tar.gz::https://github.com/KnightOS/z80e/archive/0.5.0.tar.gz
+ md5sums = cec89fd0b0eecc63b616eabbe973ac4f
pkgname = z80e
diff --git a/PKGBUILD b/PKGBUILD
index 214e91589398..6c8d1a969598 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=z80e
-pkgver=0.4.0
+pkgver=0.5.0
pkgrel=1
license=('MIT')
pkgdesc='An emulation library and client programs for z80 calculators'
@@ -9,10 +9,11 @@ makedepends=("cmake" "asciidoc")
arch=("x86_64")
url='https://github.com/KnightOS/z80e'
source=("$pkgname-$pkgver.tar.gz::https://github.com/KnightOS/z80e/archive/$pkgver.tar.gz")
-md5sums=('cef93422186f55541be34aee0004bbb8')
+md5sums=('cec89fd0b0eecc63b616eabbe973ac4f')
build() {
cd "${pkgname}-${pkgver}"
+ echo "TARGET_LINK_LIBRARIES(z80e-sdl SDL2)" >> frontends/sdl/CMakeLists.txt
cmake -Denable-sdl=YES -DCMAKE_INSTALL_PREFIX=/usr .
make
}