summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Baudisch2018-04-20 07:04:50 +0200
committerJan Baudisch2018-04-20 07:04:50 +0200
commitc3e719999ccc2bb3ce6f3bca61c181965166fd83 (patch)
tree1e6cf2759337bd0a3f25212beb7f3a1dabf23104
downloadaur-c3e719999ccc2bb3ce6f3bca61c181965166fd83.tar.gz
initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD54
-rw-r--r--z88dk.sh1
3 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..933a5b24c57f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = z88dk-git
+ pkgdesc = The development kit for over fifty z80 machines - c compiler, assembler, linker, libraries.
+ pkgver = de7d7119a
+ pkgrel = 1
+ url = https://www.z88dk.org
+ arch = x86_64
+ license = custom: The Clarified Artistic License
+ depends = perl
+ provides = z88dk
+ conflicts = z88dk
+ source = z88dk-git::git+https://github.com/z88dk/z88dk.git
+ source = z88dk.sh
+ source = unixem::git+https://github.com/z88dk/UNIXem.git
+ source = optparse::git+https://github.com/skeeto/optparse.git
+ source = uthash::git+https://github.com/z88dk/uthash.git
+ sha256sums = SKIP
+ sha256sums = d9e302908dd3355440901254c48ffa43af273ec710ce442db77406c378f1942d
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = z88dk-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..181aed25673d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Jan Baudisch <dev@baudisch.xyz>
+pkgname=z88dk-git
+pkgver=de7d7119a
+pkgrel=1
+pkgdesc="The development kit for over fifty z80 machines - c compiler, assembler, linker, libraries."
+arch=("x86_64")
+url="https://www.z88dk.org"
+license=("custom: The Clarified Artistic License")
+depends=("perl")
+provides=("z88dk")
+conflicts=("z88dk")
+source=("$pkgname::git+https://github.com/z88dk/z88dk.git"
+ "z88dk.sh"
+ "unixem::git+https://github.com/z88dk/UNIXem.git"
+ "optparse::git+https://github.com/skeeto/optparse.git"
+ "uthash::git+https://github.com/z88dk/uthash.git")
+sha256sums=("SKIP"
+ "d9e302908dd3355440901254c48ffa43af273ec710ce442db77406c378f1942d"
+ "SKIP"
+ "SKIP"
+ "SKIP")
+
+pkgver() {
+ cd "$pkgname"
+ git rev-parse --short HEAD
+}
+
+prepare() {
+ cd "$pkgname"
+ git submodule init
+ git config submodule.UNIXem.url $srcdir/unixem
+ git config submodule.optparse.url $srcdir/optparse
+ git config submodule.uthash.url $srcdir/uthash
+ git submodule update
+}
+
+build() {
+ cd "$pkgname"
+ chmod +x build.sh
+ ./build.sh
+}
+
+package() {
+ # would not create paths otherwise
+ export INSTALL="install -D"
+
+ cd "$pkgname"
+
+ make prefix="/usr" DESTDIR="$pkgdir" install
+
+ install -Ddm755 "$pkgdir/etc/profile.d"
+ install -m644 "$srcdir/z88dk.sh" "$pkgdir/etc/profile.d/z88dk.sh"
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/z88dk/LICENSE"
+}
diff --git a/z88dk.sh b/z88dk.sh
new file mode 100644
index 000000000000..f5671d8c6792
--- /dev/null
+++ b/z88dk.sh
@@ -0,0 +1 @@
+export ZCCCFG=/usr/share/z88dk/lib/config