summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraxionl2018-05-14 18:03:26 +0800
committeraxionl2018-05-14 18:03:26 +0800
commit78991d79bdc7d1131779eaf6e7f2befbf27e1cb3 (patch)
tree05e2ce961d0aeaa7b196a2e0a5b5211ab05e37e6
downloadaur-78991d79bdc7d1131779eaf6e7f2befbf27e1cb3.tar.gz
Add package zafiro-icon-theme
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD22
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..744139367e4c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = zafiro-icon-theme
+ pkgdesc = A icon pack flat with light colors.
+ pkgver = 0.1.8
+ pkgrel = 1
+ url = https://github.com/keeferrourke/zafiro-icon-theme
+ arch = any
+ license = Artistic2.0
+ source = https://github.com/zayronxio/Zafiro-icons/archive/v0.1.8.tar.gz
+ sha256sums = e6d03ff73a939327761a271a194bc07b0c85b8c64f74644d4081d6a3befa6ac1
+
+pkgname = zafiro-icon-theme
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f10372aca65
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: ArielAxionL <axionl@aosc.io>
+
+pkgname=('zafiro-icon-theme')
+pkgver=0.1.8
+pkgrel=1
+pkgdesc="A icon pack flat with light colors."
+arch=('any')
+url="https://github.com/keeferrourke/$pkgname"
+license=('Artistic2.0')
+source=("https://github.com/zayronxio/Zafiro-icons/archive/v$pkgver.tar.gz")
+sha256sums=('e6d03ff73a939327761a271a194bc07b0c85b8c64f74644d4081d6a3befa6ac1')
+
+package() {
+ install -dm 755 $pkgdir/usr/share/icons
+ dir=$srcdir/Zafiro-icons-$pkgver
+ install -Dm644 $dir/LICENSE.md $pkgdir/usr/share/license/$pkgname/LICENSE
+
+ mv "$dir/previews/system apps.png" $dir/previews/system-apps.png
+ cp -dr --no-preserve='ownership' $dir $pkgdir/usr/share/icons/$pkgname
+}
+
+# vim: ts=2 sw=2 et: \ No newline at end of file