summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2023-11-05 08:19:32 +0100
committerChristopher Arndt2023-11-05 08:19:32 +0100
commit70aed35a134bdbc0539fe7e5e5d203524896f097 (patch)
tree18189f70852bdc44ad1a5489df3a9681bf7531ad
parent820a5597c7c821fd7b0b33616de58ed643c104a1 (diff)
downloadaur-70aed35a134bdbc0539fe7e5e5d203524896f097.tar.gz
General PKGBUILD overhaul
-rw-r--r--.SRCINFO43
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD101
3 files changed, 106 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 38ae0ac262f5..e6c3791b1822 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,18 @@
pkgbase = zam-plugins-git
pkgdesc = Collection of LADSPA/LV2/VST/JACK audio plugins for high-quality processing (git version)
- pkgver = 3.14.r0.ge7077fc
- pkgrel = 2
+ pkgver = 4.2.r0.g19307a5
+ pkgrel = 1
url = https://github.com/zamaudio/zam-plugins
arch = x86_64
+ groups = clap-plugins
groups = ladspa-plugins
groups = lv2-plugins
groups = pro-audio
groups = vst-plugins
+ groups = vst3-plugins
license = GPL2
+ makedepends = alsa-lib
+ makedepends = dbus
makedepends = gendesk
makedepends = git
makedepends = ladspa
@@ -20,17 +24,39 @@ pkgbase = zam-plugins-git
depends = glibc
depends = libglvnd
depends = libx11
- optdepends = jack: for standalone applications
+ depends = libxcursor
+ depends = libxext
+ depends = libxrandr
+ optdepends = clap-host: to load the CLAP format plugins
+ optdepends = jack: to run the standalone applications
+ optdepends = ladspa-host: to load the LADSPA format plugins
+ optdepends = lv2-host: to load the LV2 format plugins
+ optdepends = vst-host: to load the VST2 format plugins
+ optdepends = vst3-host: to load the VST3 format plugins
provides = zam-plugins
- provides = zam-plugins=3.14
+ provides = zam-plugins-clap
+ provides = zam-plugins-ladspa
+ provides = zam-plugins-lv2
+ provides = zam-plugins-standalone
+ provides = zam-plugins-vst
+ provides = zam-plugins-vst3
conflicts = zam-plugins
conflicts = zamplugins
+ conflicts = zam-plugins
+ conflicts = zam-plugins-clap
+ conflicts = zam-plugins-ladspa
+ conflicts = zam-plugins-lv2
+ conflicts = zam-plugins-standalone
+ conflicts = zam-plugins-vst
+ conflicts = zam-plugins-vst3
source = zam-plugins::git+https://github.com/zamaudio/zam-plugins.git
- source = git+https://github.com/DISTRHO/DPF.git
+ source = dpf::git+https://github.com/DISTRHO/DPF.git
+ source = pugl::git+https://github.com/DISTRHO/pugl.git
source = zam-plugins.directory
source = zam-plugins.menu
md5sums = SKIP
md5sums = SKIP
+ md5sums = SKIP
md5sums = 99e66b26922172cd212914230a557108
md5sums = 5be3eb16b1d91ae653af25c8dcddd70f
@@ -39,6 +65,11 @@ pkgname = zam-plugins-git
depends = glibc
depends = libglvnd
depends = libx11
+ depends = libxcursor
+ depends = libxext
+ depends = libxrandr
+ depends = libasound.so
+ depends = libdbus-1.so
+ depends = libGL.so
depends = libsamplerate.so
depends = libzita-convolver.so
-
diff --git a/.gitignore b/.gitignore
index eeb05234d321..bdf68b691dfe 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,6 @@
-DPF/
+dpf/
+pugl/
pkg/
src/
zam-plugins/
-zam-plugins-git-*.pkg.tar.xz
-zam-plugins-git-*.pkg.tar.zst
+zam-plugins-git-*.pkg.tar.*
diff --git a/PKGBUILD b/PKGBUILD
index 2ae8d9d9e0ae..53834ecc5fd3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,52 @@
# Contributor: Haskellfant <moritz.kiefer@purelyfunctional.org
_pkgname=zam-plugins
-pkgname="${_pkgname}-git"
-pkgver=3.14.r0.ge7077fc
-pkgrel=2
-pkgdesc="Collection of LADSPA/LV2/VST/JACK audio plugins for high-quality processing (git version)"
-arch=('x86_64')
-url="https://github.com/zamaudio/zam-plugins"
-license=('GPL2')
-groups=('ladspa-plugins' 'lv2-plugins' 'pro-audio' 'vst-plugins')
-depends=('gcc-libs' 'glibc' 'libglvnd' 'libx11')
-makedepends=('gendesk' 'git' 'ladspa' 'libsamplerate' 'jack' 'lv2' 'zita-convolver')
-optdepends=('jack: for standalone applications')
-provides=("${_pkgname}" "${_pkgname}=${pkgver/.r*/}")
-conflicts=("${_pkgname}" 'zamplugins')
-source=("${_pkgname}::git+https://github.com/zamaudio/${_pkgname}.git"
- 'git+https://github.com/DISTRHO/DPF.git'
+pkgname=$_pkgname-git
+pkgver=4.2.r0.g19307a5
+pkgrel=1
+pkgdesc='Collection of LADSPA/LV2/VST/JACK audio plugins for high-quality processing (git version)'
+arch=(x86_64)
+url='https://github.com/zamaudio/zam-plugins'
+license=(GPL2)
+groups=(clap-plugins ladspa-plugins lv2-plugins pro-audio vst-plugins vst3-plugins)
+depends=(gcc-libs glibc libglvnd libx11 libxcursor libxext libxrandr)
+makedepends=(alsa-lib dbus gendesk git ladspa libsamplerate jack lv2 zita-convolver)
+optdepends=(
+ 'clap-host: to load the CLAP format plugins'
+ 'jack: to run the standalone applications'
+ 'ladspa-host: to load the LADSPA format plugins'
+ 'lv2-host: to load the LV2 format plugins'
+ 'vst-host: to load the VST2 format plugins'
+ 'vst3-host: to load the VST3 format plugins'
+)
+provides=(
+ $_pkgname
+ $_pkgname-clap
+ $_pkgname-ladspa
+ $_pkgname-lv2
+ $_pkgname-standalone
+ $_pkgname-vst
+ $_pkgname-vst3
+)
+conflicts=(
+ $_pkgname
+ zamplugins
+ $_pkgname
+ $_pkgname-clap
+ $_pkgname-ladspa
+ $_pkgname-lv2
+ $_pkgname-standalone
+ $_pkgname-vst
+ $_pkgname-vst3
+)
+source=("$_pkgname::git+https://github.com/zamaudio/$_pkgname.git"
+ 'dpf::git+https://github.com/DISTRHO/DPF.git'
+ 'pugl::git+https://github.com/DISTRHO/pugl.git'
'zam-plugins.directory'
'zam-plugins.menu')
md5sums=('SKIP'
'SKIP'
+ 'SKIP'
'99e66b26922172cd212914230a557108'
'5be3eb16b1d91ae653af25c8dcddd70f')
@@ -30,19 +57,22 @@ _names=('zamaximx2' 'zamulticomp' 'zammulticompx2' 'zamautosat' 'zamcomp'
'zamgatex2' 'zamgrains' 'zamheadx2' 'zamphono' 'zamtube' 'zamverb')
pkgver() {
- cd "${srcdir}/${_pkgname}"
+ cd $_pkgname
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "${srcdir}/${_pkgname}"
+ cd $_pkgname
+ git submodule init
+ git submodule set-url dpf "$srcdir"/dpf
+ git -c protocol.file.allow=always submodule update
+
+ cd dpf
git submodule init
- git config submodule.dpf.url "${srcdir}/DPF"
- git submodule update
+ git submodule set-url dgl/src/pugl-upstream "$srcdir"/pugl
+ git -c protocol.file.allow=always submodule update
- # use system zita-convolver
- sed -e 's|\"../../lib/zita-convolver-3.1.0/zita-convolver.h\"|<zita-convolver.h>|' \
- -i plugins/Zam{Verb,HeadX2}/convolution.{cpp,hpp}
+ cd ..
declare -A exec_names=(
["zamaximx2"]="ZaMaximX2"
@@ -103,8 +133,8 @@ prepare() {
)
for name in "${_names[@]}"; do
gendesk -f -n \
- --pkgname "com.zamaudio.${name}" \
- --name "${name}" \
+ --pkgname "com.zamaudio.$name" \
+ --name "$name" \
--exec "${exec_names[$name]}" \
--pkgdesc "${comments[$name]}" \
--genericname "${generic[$name]}"
@@ -112,22 +142,23 @@ prepare() {
}
build() {
- cd "${srcdir}/${_pkgname}"
+ cd $_pkgname
export HAVE_ZITA_CONVOLVER=true
make
}
package() {
- cd "${srcdir}/${_pkgname}"
- depends+=('libsamplerate.so' 'libzita-convolver.so')
- make DESTDIR="$pkgdir/" PREFIX='/usr' install
+ depends+=(libasound.so libdbus-1.so libGL.so libsamplerate.so libzita-convolver.so)
+ cd $_pkgname
+ make DESTDIR="$pkgdir" PREFIX=/usr install
# XDG desktop integration
- install -vDm 644 *.desktop -t "${pkgdir}/usr/share/applications"
- install -vDm 644 "${srcdir}/${_pkgname}.menu" \
- -t "${pkgdir}/etc/xdg/menus/applications-merged/"
- install -vDm 644 "${srcdir}/${_pkgname}.directory" \
- -t "${pkgdir}/usr/share/desktop-directories/"
+ install -vDm 644 *.desktop \
+ -t "$pkgdir"/usr/share/applications
+ install -vDm 644 "$srcdir"/$_pkgname.menu \
+ -t "$pkgdir"/etc/xdg/menus/applications-merged/
+ install -vDm 644 "$srcdir"/$_pkgname.directory \
+ -t "$pkgdir"/usr/share/desktop-directories
# docs
- install -t "${pkgdir}/usr/share/doc/${pkgname}/" \
- -vDm644 {README.md,changelog}
+ install -vDm644 README.md changelog \
+ -t "$pkgdir"/usr/share/doc/$pkgname
}