summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMorgan2015-07-01 22:48:08 +0000
committerMorgan2015-07-01 22:48:08 +0000
commitae9f0a28947184b5ce76d52c4299eac13bd08e94 (patch)
tree6658e6dd6bfb02816887af61ce93fb17a77e8804
downloadaur-ae9f0a28947184b5ce76d52c4299eac13bd08e94.tar.gz
v2.1
-rw-r--r--.SRCINFO26
-rw-r--r--LICENSE.txt39
-rw-r--r--PKGBUILD80
-rw-r--r--zandronum.install4
4 files changed, 149 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bf3fd3a79f30
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+# Generated by makepkg 4.2.1
+# Thu Apr 9 03:29:00 UTC 2015
+pkgbase = zandronum2
+ pkgdesc = OpenGL ZDoom port with Client/Server multiplayer.
+ pkgver = 2.1
+ pkgrel = 1
+ url = http://zandronum.com/
+ install = zandronum.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = sdl
+ depends = gtk2
+ depends = libjpeg6-turbo
+ depends = glu
+ depends = openssl
+ optdepends = timidity++: midi support
+ optdepends = freedoom: free IWAD
+ conflicts = ('zandronum-hg' 'zandronum')
+ source = http://zandronum.com/downloads/zandronum2.0-linux-x86_64.tar.bz2
+ source = LICENSE.txt
+ md5sums = 60b97dbc4f521d7c218c14d17cdf6841
+ md5sums = 58c2c8b15c886b838dc2ed5186361507
+
+pkgname = zandronum2
+
diff --git a/LICENSE.txt b/LICENSE.txt
new file mode 100644
index 000000000000..19a5bc0e86bd
--- /dev/null
+++ b/LICENSE.txt
@@ -0,0 +1,39 @@
+Zandronum
+Copyright (c) 2012, Zandronum Development Team
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are met:
+
+1. Redistributions of source code must retain the above copyright notice, this
+ list of conditions and the following disclaimer.
+2. Redistributions in binary form must reproduce the above copyright notice,
+ this list of conditions and the following disclaimer in the documentation
+ and/or other materials provided with the distribution.
+3. Neither the name of the Zandronum Development Team nor the names of its
+ contributors may be used to endorse or promote products derived from this
+ software without specific prior written permission.
+4. Redistributions in any form must be accompanied by information on how to
+ obtain complete source code for the software and any accompanying software
+ that uses the software. The source code must either be included in the
+ distribution or be available for no more than the cost of distribution plus
+ a nominal fee, and must be freely redistributable under reasonable
+ conditions. For an executable file, complete source code means the source
+ code for all modules it contains. It does not include source code for
+ modules or files that typically accompany the major components of the
+ operating system on which the executable file runs.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
+AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE
+FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
+CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
+OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+The above copyright and license notice applies to distributions of Zandronum in
+source and binary form. Some source files contain additional notices of
+original copyright by their contributors; see each source for details. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..224d40b7e5b3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,80 @@
+# Maintainer: Morgan Bohn <morgan.bohn at gmail dot com>
+# Based on the skulltag package by Mikael Eriksson <mikael_eriksson@miffe.org>
+# and Sean Streeter <anubis2591 at gmail dot com>
+# and Robert La Spina <rkidlaspina at gmail dot com>
+pkgname=zandronum2
+pkgver=2.1
+pkgrel=1
+pkgdesc="OpenGL ZDoom port with Client/Server multiplayer."
+arch=('i686' 'x86_64')
+url="http://zandronum.com/"
+license=('custom')
+conflicts=('zandronum-hg', 'zandronum')
+#makedepends=('cmake' 'mercurial' 'yasm' 'mesa') # Not sure if it needs yasm.
+depends=('sdl' 'gtk2' 'libjpeg6-turbo' 'glu' 'openssl')
+optdepends=('timidity++: midi support'
+ 'freedoom: free IWAD')
+install=zandronum.install
+
+if [ "$CARCH" == "i686" ];then
+ source=(
+ "http://zandronum.com/downloads/${pkgname}${pkgver}-linux-x86.tar.bz2"
+ "LICENSE.txt"
+ )
+ md5sums=(
+ '5e4c65146c82111eb404ae0aef69fbcf'
+ '58c2c8b15c886b838dc2ed5186361507'
+ )
+ _64=
+fi
+
+if [ "$CARCH" == "x86_64" ]; then
+ source=(
+ "http://zandronum.com/downloads/${pkgname}${pkgver}-linux-x86_64.tar.bz2"
+ "LICENSE.txt"
+ )
+ md5sums=(
+ '60b97dbc4f521d7c218c14d17cdf6841'
+ '58c2c8b15c886b838dc2ed5186361507'
+ )
+ _64=64
+fi
+
+
+build() {
+ cd $srcdir
+
+ cat > zandronum.sh << EOF
+#!/bin/sh
+export LD_LIBRARY_PATH=/usr/share/zandronum/lib
+exec /usr/share/zandronum/zandronum "\$@"
+EOF
+
+ cat > zandronum-server.sh << EOF
+#!/bin/sh
+export LD_LIBRARY_PATH=/usr/share/zandronum/lib
+exec /usr/share/zandronum/zandronum-server "\$@"
+EOF
+
+}
+
+package(){
+ cd $srcdir
+
+ install -Dm644 "zandronum.pk3" "$pkgdir/usr/share/zandronum/zandronum.pk3"
+ #install -Dm644 "brightmaps.pk3" "$pkgdir/usr/share/zandronum/brightmaps.pk3"
+ install -Dm644 "skulltag_actors.pk3" "$pkgdir/usr/share/zandronum/skulltag_actors.pk3"
+ install -Dm755 "liboutput_sdl.so" "$pkgdir/usr/share/zandronum/lib/liboutput_sdl.so"
+ install -Dm755 "zandronum" "$pkgdir/usr/share/zandronum/zandronum"
+ install -Dm755 "zandronum-server" "$pkgdir/usr/share/zandronum/zandronum-server"
+ install -Dm755 "zandronum.sh" "$pkgdir/usr/bin/zandronum"
+ install -Dm755 "zandronum-server.sh" "$pkgdir/usr/bin/zandronum-server"
+ install -Dm755 "libfmodex${_64}-4.24.16.so" "$pkgdir/usr/share/zandronum/lib/libfmodex${_64}-4.24.16.so"
+
+# ln -s "/usr/lib/libcrypto.so" "$pkgdir/usr/share/zandronum/lib/libcrypto.so.0.9.8"
+# ln -s "/usr/lib/libssl.so" "$pkgdir/usr/share/zandronum/lib/libssl.so.0.9.8"
+
+ install -Dm644 "LICENSE.txt" "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/zandronum.install b/zandronum.install
new file mode 100644
index 000000000000..1ff7aaefa722
--- /dev/null
+++ b/zandronum.install
@@ -0,0 +1,4 @@
+## arg 1: the new package version
+post_install() {
+ echo ":: Zandronum looks for IWADs (e.g. doom2.wad) in CWD, ~/.zandronum and /usr/local/share"
+}