summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2020-05-01 20:31:19 +0000
committerAntonio Rojas2020-05-01 20:31:19 +0000
commit8076b6220e3d294b9d3616af1048acecba8086df (patch)
treec1d6f9892960874240d51611158a71bf369e5c83
downloadaur-8076b6220e3d294b9d3616af1048acecba8086df.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD37
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a9fc69af3538
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = zapcc
+ pkgdesc = C++ compiler based on Clang, but significantly faster
+ pkgver = 7.0.325000
+ pkgrel = 3
+ url = https://zapcc.com/
+ arch = x86_64
+ license = custom
+ makedepends = cmake
+ makedepends = git
+ makedepends = ninja
+ depends = python
+ depends = z3
+ conflicts = clang
+ source = git+https://github.com/yrnkrn/zapcc.git#commit=9bd04e7
+ sha256sums = SKIP
+
+pkgname = zapcc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3c799c249f25
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
+# Contributor: Evangelos Foutras <evangelos@foutrelis.com>
+
+pkgname=zapcc
+pkgver=7.0.325000
+pkgrel=3
+pkgdesc='C++ compiler based on Clang, but significantly faster'
+arch=('x86_64')
+license=('custom')
+url='https://zapcc.com/'
+depends=('python' 'z3')
+makedepends=('cmake' 'git' 'ninja')
+conflicts=('clang')
+source=("git+https://github.com/yrnkrn/zapcc.git#commit=9bd04e7")
+sha256sums=('SKIP')
+
+build() {
+ mkdir -p build
+ cd build
+ cmake "../$pkgname" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLLVM_ENABLE_WARNINGS=OFF \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DPYTHON_EXECUTABLE=/usr/bin/python \
+ -G Ninja
+ ninja
+}
+
+package() {
+ cd build
+ for component in clang-headers zapcc zapccs; do
+ DESTDIR="$pkgdir" cmake -DCOMPONENT="$component" -P ./cmake_install.cmake
+ done
+ install -Dm644 ../$pkgname/LICENSE.TXT "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim: ts=2 sw=2 et: