summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMusiclover3822022-09-25 12:47:27 +0200
committerMusiclover3822022-09-25 12:47:27 +0200
commit06df9e188b6f2285a6e8932d405f13ad57a4404b (patch)
treeb01161336461956c13c3ae0e0b2e096cd4ed59c1
downloadaur-06df9e188b6f2285a6e8932d405f13ad57a4404b.tar.gz
Initial import: 4.4
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b62eedf35ab6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = zapzap
+ pkgdesc = WhatsApp desktop application written in Pyqt6 + PyQt6-WebEngine
+ pkgver = 4.4
+ pkgrel = 1
+ url = https://github.com/rafatosta/zapzap
+ arch = x86_64
+ license = GPL3
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ depends = python-pyqt6
+ depends = python-pyqt6-webengine
+ depends = dbus-python
+ source = https://github.com/rafatosta/zapzap/archive/v4.4.tar.gz
+ sha256sums = 2fdb9ee666f92ce2f28bc40ac0dd50da158897a7f268abc8b01a7343632d6ffd
+
+pkgname = zapzap
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7823d8286a99
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: musiclover <musiclover382@protonmail.com>
+
+pkgname=zapzap
+_pkgname=com.rtosta.zapzap
+pkgver=4.4
+pkgrel=1
+pkgdesc="WhatsApp desktop application written in Pyqt6 + PyQt6-WebEngine"
+arch=('x86_64')
+url="https://github.com/rafatosta/$pkgname"
+license=('GPL3')
+depends=('python-pyqt6' 'python-pyqt6-webengine' 'dbus-python')
+makedepends=('python-build' 'python-installer' 'python-wheel')
+source=($url/archive/v$pkgver.tar.gz)
+sha256sums=('2fdb9ee666f92ce2f28bc40ac0dd50da158897a7f268abc8b01a7343632d6ffd')
+
+build() {
+ cd $pkgname-$pkgver
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd $pkgname-$pkgver
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm644 share/icons/$_pkgname.svg "$pkgdir"/usr/share/icons/hicolor/scalable/apps/$_pkgname.svg
+ install -Dm664 share/applications/$_pkgname.desktop "$pkgdir"/usr/share/applications/$_pkgname.desktop
+ install -Dm664 share/metainfo/$_pkgname.appdata.xml "$pkgdir"/share/metainfo/$_pkgname.appdata.xml
+}