summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMattia Borda2023-01-29 10:00:33 +0100
committerMattia Borda2023-01-29 10:00:33 +0100
commitefcb23eb450fda511acdea6f51a180ad197e8d53 (patch)
tree8dae9ec02b5619f680b22da80d1b64c196174d23
parenta1d6f751c1070001525deec78c20614c39c3b457 (diff)
downloadaur-efcb23eb450fda511acdea6f51a180ad197e8d53.tar.gz
Update to 4.4.4
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD24
2 files changed, 16 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ba5f84e109d..40cbc5b84bb7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = zapzap
pkgdesc = WhatsApp desktop application written in Pyqt6 + PyQt6-WebEngine
- pkgver = 4.4.3
- pkgrel = 2
+ pkgver = 4.4.4
+ pkgrel = 1
url = https://github.com/rafatosta/zapzap
arch = x86_64
license = GPL3
+ makedepends = git
makedepends = python-build
makedepends = python-installer
makedepends = python-setuptools
@@ -13,7 +14,7 @@ pkgbase = zapzap
depends = python-pyqt6-webengine
depends = dbus-python
optdepends = hunspell: spell check
- source = https://github.com/rafatosta/zapzap/archive/v4.4.3.tar.gz
- sha256sums = 1ed202ea2363702bceb3ccf9eac23947846202215c7175c7ff61ba43f96e27bc
+ source = git+https://github.com/rafatosta/zapzap#tag=v4.4.4
+ b2sums = SKIP
pkgname = zapzap
diff --git a/PKGBUILD b/PKGBUILD
index e69605bbd006..5ff7c94c47e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,27 +2,25 @@
pkgname=zapzap
_pkgname=com.rtosta.zapzap
-pkgver=4.4.3
-pkgrel=2
-pkgdesc="WhatsApp desktop application written in Pyqt6 + PyQt6-WebEngine"
-arch=('x86_64')
+pkgver=4.4.4
+pkgrel=1
+pkgdesc='WhatsApp desktop application written in Pyqt6 + PyQt6-WebEngine'
+arch=(x86_64)
url="https://github.com/rafatosta/$pkgname"
-license=('GPL3')
+license=(GPL3)
depends=('python-pyqt6' 'python-pyqt6-webengine' 'dbus-python')
-makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
-optdepends=(
- 'hunspell: spell check'
- )
-source=($url/archive/v$pkgver.tar.gz)
-sha256sums=('1ed202ea2363702bceb3ccf9eac23947846202215c7175c7ff61ba43f96e27bc')
+makedepends=('git' 'python-build' 'python-installer' 'python-setuptools' 'python-wheel')
+optdepends=('hunspell: spell check')
+source=(git+$url#tag=v$pkgver)
+b2sums=(SKIP)
build() {
- cd $pkgname-$pkgver
+ cd $pkgname
python -m build --wheel --no-isolation
}
package() {
- cd $pkgname-$pkgver
+ cd $pkgname
python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 share/icons/$_pkgname.svg "$pkgdir"/usr/share/icons/hicolor/scalable/apps/$_pkgname.svg
install -Dm664 share/applications/$_pkgname.desktop "$pkgdir"/usr/share/applications/$_pkgname.desktop