summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortxtsd2022-04-30 16:37:39 +0530
committertxtsd2022-04-30 16:37:39 +0530
commit74e33737a83f67d5b2dc9039bab5ef9999a131c9 (patch)
tree16d69a796afddca994881bbf0e7b412ecbe3a2f8
parentbb010d323a8dbf0dbe94681a6003084dcc5855d5 (diff)
downloadaur-74e33737a83f67d5b2dc9039bab5ef9999a131c9.tar.gz
chore: Sync with upstream
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD27
2 files changed, 17 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 629e0b063e08..893d1fbc2d88 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,18 @@
pkgbase = zaread-git
pkgdesc = A (very) lightweight MS Office file reader
- pkgver = 1.0
+ pkgver = r47.9239db1
pkgrel = 1
url = https://github.com/paoloap/zaread
arch = any
license = GPL
makedepends = git
depends = zathura
- depends = libreoffice
+ optdepends = libreoffice
+ optdepends = calibre
+ optdepends = md2pdf
provides = zaread
conflicts = zaread
source = git+https://github.com/paoloap/zaread.git
- source = makefile.patch::https://github.com/paoloap/zaread/pull/1.patch
- source = markdown.patch::https://github.com/paoloap/zaread/pull/2.patch
- source = cache.patch::https://github.com/paoloap/zaread/pull/4.patch
sha256sums = SKIP
- sha256sums = 22f32a9b53acf1ebbfffd2c2b550249691af5b93ec6ffbce27deaec9f0423456
- sha256sums = a672ca390255a51b99f44998ae6c9955db5caea6051ccf1aef0610b1d00bc1e4
- sha256sums = daaabcb0c7728947567ecad716c6abdb55b2fb04cd7b5db9f600311748f56f39
pkgname = zaread-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 74a06d0849ae..67dd560556c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,31 @@
-# Maintainer: Jacob Gogichaishvili <jggsecondary@gmail.com>
+# Maintainer: Dawson Dias <thexerothermicsclerodermoid@gmail.com>
+# Contributor: Jacob Gogichaishvili <jggsecondary@gmail.com>
_pkgname="zaread"
pkgname="$_pkgname-git"
-pkgdesc="A (very) lightweight MS Office file reader"
+pkgver=r47.9239db1
+pkgrel=1
+pkgdesc="A (very) lightweight ebook and Office document reader"
arch=("any")
url="https://github.com/paoloap/zaread"
license=("GPL")
-depends=("zathura" "libreoffice" "pandoc")
+depends=("zathura")
+optdepends=("libreoffice" "calibre" "md2pdf")
makedepends=("git")
provides=("zaread")
conflicts=("zaread")
-source=('git+https://github.com/paoloap/zaread.git' 'markdown.patch::https://github.com/paoloap/zaread/pull/2.patch' 'cache.patch::https://github.com/paoloap/zaread/pull/4.patch')
-pkgver=1.0
-pkgrel=1
-sha256sums=('SKIP'
- 'a672ca390255a51b99f44998ae6c9955db5caea6051ccf1aef0610b1d00bc1e4'
- 'daaabcb0c7728947567ecad716c6abdb55b2fb04cd7b5db9f600311748f56f39')
+source=('git+https://github.com/paoloap/zaread.git')
+sha256sums=('SKIP')
-prepare() {
+pkgver() {
cd "$srcdir/$_pkgname"
- # Add markdown patch so zaread can read markdown
- git am "$srcdir/markdown.patch"
- # Add cache patch so zaread uses the XDG-specification directory for cache rather than its own.
- git am "$srcdir/cache.patch"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
cd "$srcdir/$_pkgname"
mkdir -p "$pkgdir/${PREFIX:-usr}/bin"
install -Dm755 "$srcdir/$_pkgname/$_pkgname" "$pkgdir/${PREFIX:-usr}/bin/"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$_pkgname/"
+ install -Dm644 README.md -t "$pkgdir/usr/share/doc/$_pkgname/"
}