summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJacob Gogichaishvili2021-02-15 21:05:59 +0400
committerJacob Gogichaishvili2021-02-15 21:05:59 +0400
commitbb010d323a8dbf0dbe94681a6003084dcc5855d5 (patch)
treeb0d1d14a2fe1b8d2e2aa3197465dd87d04bd58fe
downloadaur-bb010d323a8dbf0dbe94681a6003084dcc5855d5.tar.gz
Initial Commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD32
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..629e0b063e08
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = zaread-git
+ pkgdesc = A (very) lightweight MS Office file reader
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/paoloap/zaread
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = zathura
+ depends = libreoffice
+ provides = zaread
+ conflicts = zaread
+ source = git+https://github.com/paoloap/zaread.git
+ source = makefile.patch::https://github.com/paoloap/zaread/pull/1.patch
+ source = markdown.patch::https://github.com/paoloap/zaread/pull/2.patch
+ source = cache.patch::https://github.com/paoloap/zaread/pull/4.patch
+ sha256sums = SKIP
+ sha256sums = 22f32a9b53acf1ebbfffd2c2b550249691af5b93ec6ffbce27deaec9f0423456
+ sha256sums = a672ca390255a51b99f44998ae6c9955db5caea6051ccf1aef0610b1d00bc1e4
+ sha256sums = daaabcb0c7728947567ecad716c6abdb55b2fb04cd7b5db9f600311748f56f39
+
+pkgname = zaread-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..74a06d0849ae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Jacob Gogichaishvili <jggsecondary@gmail.com>
+
+_pkgname="zaread"
+pkgname="$_pkgname-git"
+pkgdesc="A (very) lightweight MS Office file reader"
+arch=("any")
+url="https://github.com/paoloap/zaread"
+license=("GPL")
+depends=("zathura" "libreoffice" "pandoc")
+makedepends=("git")
+provides=("zaread")
+conflicts=("zaread")
+source=('git+https://github.com/paoloap/zaread.git' 'markdown.patch::https://github.com/paoloap/zaread/pull/2.patch' 'cache.patch::https://github.com/paoloap/zaread/pull/4.patch')
+pkgver=1.0
+pkgrel=1
+sha256sums=('SKIP'
+ 'a672ca390255a51b99f44998ae6c9955db5caea6051ccf1aef0610b1d00bc1e4'
+ 'daaabcb0c7728947567ecad716c6abdb55b2fb04cd7b5db9f600311748f56f39')
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+ # Add markdown patch so zaread can read markdown
+ git am "$srcdir/markdown.patch"
+ # Add cache patch so zaread uses the XDG-specification directory for cache rather than its own.
+ git am "$srcdir/cache.patch"
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ mkdir -p "$pkgdir/${PREFIX:-usr}/bin"
+ install -Dm755 "$srcdir/$_pkgname/$_pkgname" "$pkgdir/${PREFIX:-usr}/bin/"
+}