summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOliver Bandel2017-01-25 14:23:12 +0100
committerOliver Bandel2017-01-25 14:23:12 +0100
commit311e1ba1f58873ed29a37d4c64c7830387eaaf2c (patch)
tree153325ffee0cfba973c289d58e550e6bcc44d961
parent1d7a9c1466e33931364f957ef08d52efaff4d094 (diff)
downloadaur-311e1ba1f58873ed29a37d4c64c7830387eaaf2c.tar.gz
Zarith-sources now from github; rational numbers now mentioned in pkgdesc.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e93f671a2ead..733e96eec824 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = zarith
- pkgdesc = Implements arithmetic and logical operations over arbitrary-precision integers
+ pkgdesc = Implements arithmetic and logical operations over arbitrary-precision integers and rational numbers
pkgver = 1.4.1
- pkgrel = 1
- url = http://forge.ocamlcore.org/projects/zarith
+ pkgrel = 2
+ url = https://github.com/ocaml/Zarith
arch = x86_64
arch = i686
license = GPL2
makedepends = ocaml>=3.08
depends = glibc
- source = http://forge.ocamlcore.org/frs/download.php/1574/zarith-1.4.1.tgz
- md5sums = 9ab2482d57f632c9cb3d10149138bc6e
+ source = https://github.com/ocaml/Zarith/archive/release-1.4.1.tar.gz
+ md5sums = 6b4886b457c1ee8c28763fe26cff9e48
pkgname = zarith
diff --git a/PKGBUILD b/PKGBUILD
index 7428dc0a847a..86c5d1a5e06f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,25 +4,25 @@
pkgname=zarith
pkgver=1.4.1
-pkgrel=1
-pkgdesc='Implements arithmetic and logical operations over arbitrary-precision integers'
+pkgrel=2
+pkgdesc='Implements arithmetic and logical operations over arbitrary-precision integers and rational numbers'
arch=(x86_64 i686)
-url='http://forge.ocamlcore.org/projects/zarith'
+url='https://github.com/ocaml/Zarith'
license=('GPL2')
depends=('glibc')
makedepends=('ocaml>=3.08')
-source=("http://forge.ocamlcore.org/frs/download.php/1574/${pkgname}-${pkgver}.tgz")
-md5sums=('9ab2482d57f632c9cb3d10149138bc6e')
+source=("https://github.com/ocaml/Zarith/archive/release-${pkgver}.tar.gz")
+md5sums=('6b4886b457c1ee8c28763fe26cff9e48')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd Zarith-release-${pkgver}
./configure -installdir "${pkgdir}/usr/lib/ocaml" # install ignores DESTDIR
make
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd Zarith-release-${pkgver}
mkdir -p "${pkgdir}/usr/lib/ocaml"
OCAMLFIND_LDCONF=ignore make install