summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBradan J. Wolbeck2018-09-11 20:59:45 -0600
committerBradan J. Wolbeck2018-09-11 20:59:45 -0600
commit0c9db55f9516f615eeaf42579b7ccd8b162a94d1 (patch)
treecc2d02089319564f1aecdf705abe6a3b82a72e83
parent9d280e64c8f61071b2c9bb3065abc4b5d76380c2 (diff)
downloadaur-0c9db55f9516f615eeaf42579b7ccd8b162a94d1.tar.gz
Updated source repository URLs and edited version scheme
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
2 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a9c37243a49..05f1d1136830 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = zasm
pkgdesc = A 2-pass assembler for the Zilog 8-bit Z80 CPU
- pkgver = 4.0.20
+ pkgver = 4.ba28f3c
pkgrel = 1
url = http://k1.spdns.de/Develop/Projects/zasm/
arch = any
license = BSD
- source = git+https://k1.spdns.de/Git/zasm-4.0.git#commit=50ddb7f8cd38d2a57a07e6b4de94cc6bfe1b6af5
- source = git+https://k1.spdns.de/Git/Libraries.git#commit=ca31f4a1677d4b6c39e71bc6ac23042cc832ecf1
+ source = git+https://bitbucket.org/megatokio/zasm.git#commit=ba28f3c573a3f9d69d929f290cf2921b43471369
+ source = git+https://bitbucket.org/megatokio/libraries.git#commit=a2d8746b559ed7c9e412cb1b5afa684e08e28c8d
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 90756d289e63..69b9ac765495 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,28 @@
-# Maintainer: Sean Enck <enckse@gmail.com>
+# Maintainer: Bradan J. Wolbeck <bwolbeck@compaqdisc.com>
+# Contributor: Sean Enck <enckse@gmail.com>
# Contributor: John K. Luebs <https://github.com/jkl1337>
pkgname=zasm
-pkgver=4.0.20
+pkgver=4.ba28f3c
pkgrel=1
pkgdesc="A 2-pass assembler for the Zilog 8-bit Z80 CPU"
arch=('any')
url="http://k1.spdns.de/Develop/Projects/zasm/"
license=('BSD')
-source=("git+https://k1.spdns.de/Git/zasm-4.0.git#commit=50ddb7f8cd38d2a57a07e6b4de94cc6bfe1b6af5"
- "git+https://k1.spdns.de/Git/Libraries.git#commit=ca31f4a1677d4b6c39e71bc6ac23042cc832ecf1")
+source=("git+https://bitbucket.org/megatokio/zasm.git#commit=ba28f3c573a3f9d69d929f290cf2921b43471369"
+
+"git+https://bitbucket.org/megatokio/libraries.git#commit=a2d8746b559ed7c9e412cb1b5afa684e08e28c8d")
sha256sums=('SKIP' 'SKIP')
build() {
- cd ${srcdir}/${pkgname}-4.0
- rm Libraries
- ln -s ../Libraries Libraries
+ cd ${srcdir}/${pkgname}
+ rmdir Libraries
+ ln -s ../libraries Libraries
cd Linux
make
}
package() {
- cd ${srcdir}/${pkgname}-4.0/Linux
+ cd ${srcdir}/${pkgname}/Linux
install -Dm755 zasm "${pkgdir}/usr/bin/zasm"
}