summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBradan J. Wolbeck (CompaqDisc)2019-09-24 18:52:33 -0600
committerBradan J. Wolbeck (CompaqDisc)2019-09-24 18:52:33 -0600
commitd04ddb7c9c2b55f8f19c3e4ac35ec84fb4823a6e (patch)
tree2081e495b0f1e9b54e54f9ce312883465de50985
parentb859bb01762cd9cc2f7a5f63d56547be42d66e43 (diff)
downloadaur-d04ddb7c9c2b55f8f19c3e4ac35ec84fb4823a6e.tar.gz
Update source to tag 4.2.5
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54072a7faad1..e9f2c8e3a06a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = zasm
pkgdesc = A 2-pass assembler for the Zilog 8-bit Z80 CPU
- pkgver = 4.2.3
+ pkgver = 4.2.5
pkgrel = 1
url = http://k1.spdns.de/Develop/Projects/zasm/
arch = any
license = BSD
- source = git+https://bitbucket.org/megatokio/zasm.git#commit=c6b043ea4018d2d76e35fe00ab345e526a574270
- source = git+https://bitbucket.org/megatokio/libraries.git#commit=a2d8746b559ed7c9e412cb1b5afa684e08e28c8d
+ source = git+https://bitbucket.org/megatokio/zasm.git#commit=39d265e481e4180c1c6681d8b1d661cc1b8136e9
+ source = git+https://bitbucket.org/megatokio/libraries.git#commit=9684213b6861bf7f9f45305f78927379f648d30c
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 5003372b9167..821e81c33b57 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,19 @@
# Contributor: John K. Luebs <https://github.com/jkl1337>
pkgname=zasm
-pkgver=4.2.3
+pkgver=4.2.5
pkgrel=1
pkgdesc="A 2-pass assembler for the Zilog 8-bit Z80 CPU"
arch=('any')
url="http://k1.spdns.de/Develop/Projects/zasm/"
license=('BSD')
-source=("git+https://bitbucket.org/megatokio/zasm.git#commit=c6b043ea4018d2d76e35fe00ab345e526a574270"
- "git+https://bitbucket.org/megatokio/libraries.git#commit=a2d8746b559ed7c9e412cb1b5afa684e08e28c8d")
+source=("git+https://bitbucket.org/megatokio/zasm.git#commit=39d265e481e4180c1c6681d8b1d661cc1b8136e9"
+ "git+https://bitbucket.org/megatokio/libraries.git#commit=9684213b6861bf7f9f45305f78927379f648d30c")
sha256sums=('SKIP' 'SKIP')
build() {
cd ${srcdir}/${pkgname}
- rmdir Libraries
+ rm -rf Libraries
ln -s ../libraries Libraries
cd Linux
make
@@ -25,3 +25,4 @@ package() {
cd ${srcdir}/${pkgname}/Linux
install -Dm755 zasm "${pkgdir}/usr/bin/zasm"
}
+