summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarti Raudsepp2013-03-04 18:03:37 +0200
committerMarti Raudsepp2013-03-04 18:03:37 +0200
commit63aefa8e499e8130b42b25b87c9aabaa36eec8bb (patch)
treeb3f09dcad98eb5e2a776e215ec28b04b045022be
downloadaur-zbar-headless.tar.gz
zbar-headless: Import; zbar version without GTK and Qt libraries
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD28
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..44a1731b61bc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = zbar-headless
+ pkgdesc = Application and library for reading bar codes from various sources (headless version)
+ pkgver = 0.10
+ pkgrel = 1
+ url = http://zbar.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ depends = imagemagick
+ depends = python2
+ provides = zbar=0.10
+ conflicts = zbar-gtk
+ conflicts = zbar-qt
+ conflicts = zbar
+ source = http://downloads.sourceforge.net/project/zbar/zbar/0.10/zbar-0.10.tar.bz2
+ md5sums = 0fd61eb590ac1bab62a77913c8b086a5
+
+pkgname = zbar-headless
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d93b691d204
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Marti Raudsepp <marti@juffo.org>
+# Contributor: Radu Andries <admiral0@tuxfamily.org>
+
+pkgname=zbar-headless
+pkgver=0.10
+pkgrel=1
+pkgdesc="Application and library for reading bar codes from various sources (headless version)"
+arch=('i686' 'x86_64')
+url="http://zbar.sourceforge.net/"
+license=('LGPL')
+depends=('imagemagick' 'python2')
+conflicts=('zbar-gtk' 'zbar-qt' 'zbar')
+provides=("zbar=$pkgver")
+source=("http://downloads.sourceforge.net/project/zbar/zbar/$pkgver/zbar-$pkgver.tar.bz2")
+
+build() {
+ cd "$srcdir/zbar-$pkgver"
+ # Video disabled: package requires the now-deprecated video4linux version 1
+ ./configure --prefix=/usr --without-qt --without-gtk --disable-video CFLAGS=-DNDEBUG
+ make
+}
+package() {
+ cd "$srcdir/zbar-$pkgver"
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et:
+md5sums=('0fd61eb590ac1bab62a77913c8b086a5')