summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYour Name2018-07-10 13:10:56 -0400
committerYour Name2018-07-10 13:10:56 -0400
commitf236b315726aaa193154aeecb2c15e64c84d9f87 (patch)
tree5cd3835561694df4d42f1923b47a19c2b7884ab7
parentecc60a705598b7fb1945d8e48833285b529dc7ef (diff)
downloadaur-f236b315726aaa193154aeecb2c15e64c84d9f87.tar.gz
add License
-rw-r--r--.SRCINFO6
-rw-r--r--LICENSE23
-rw-r--r--PKGBUILD9
3 files changed, 33 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e3911224b617..19143b082e6a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Wed Apr 25 04:27:09 UTC 2018
+# Tue Jul 10 17:10:45 UTC 2018
pkgbase = zbase32
pkgdesc = An alternate base32 encoder (not RFC 3548 compliant)
pkgver = 1.1.5
@@ -9,8 +9,10 @@ pkgbase = zbase32
license = BSD
makedepends = python2-setuptools
depends = python2
- source = https://files.pythonhosted.org/packages/da/86/d121236fc2d7f287dac1ef99e5452df36852a609bda6b9225f9aa2078139/zbase32-1.1.5.tar.gz
+ source = https://files.pythonhosted.org/packages/source/z/zbase32/zbase32-1.1.5.tar.gz
+ source = LICENSE
sha256sums = 9b25c34ba586cbbad4517af516e723599a6f38fc560f4797855a5f3051e6422f
+ sha256sums = c341afeb154cdcf20c247c8289fadd82245c89d0ea40b630c98885481c29845f
pkgname = zbase32
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..bf7641fdf8f0
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,23 @@
+Copyright (c) 2010-2015 Illumina, Inc.
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are met:
+
+1. Redistributions of source code must retain the above copyright notice, this
+ list of conditions and the following disclaimer.
+
+2. Redistributions in binary form must reproduce the above copyright notice,
+ this list of conditions and the following disclaimer in the documentation
+ and/or other materials provided with the distribution.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
+ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIEDi
+WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR
+ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
+LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
+ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
index 5a98789d28f2..65ef7235ba13 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,8 +9,10 @@ url='https://pypi.python.org/pypi/zbase32'
license=('BSD')
depends=('python2')
makedepends=('python2-setuptools')
-source=("https://files.pythonhosted.org/packages/da/86/d121236fc2d7f287dac1ef99e5452df36852a609bda6b9225f9aa2078139/zbase32-${pkgver}.tar.gz")
-sha256sums=('9b25c34ba586cbbad4517af516e723599a6f38fc560f4797855a5f3051e6422f')
+source=("https://files.pythonhosted.org/packages/source/z/zbase32/zbase32-${pkgver}.tar.gz"
+ 'LICENSE')
+sha256sums=('9b25c34ba586cbbad4517af516e723599a6f38fc560f4797855a5f3051e6422f'
+ 'c341afeb154cdcf20c247c8289fadd82245c89d0ea40b630c98885481c29845f')
build() {
cd "$srcdir/zbase32-$pkgver"
@@ -19,5 +21,6 @@ build() {
package() {
cd "$srcdir/zbase32-$pkgver"
- python2 setup.py install --root="$pkgdir" --optimize=1
+ python2 setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm 644 ../LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}