summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Cholasta2017-01-01 16:23:14 +0100
committerJan Cholasta2017-01-08 17:05:43 +0100
commit85df6b4b9c8b9b0390e79331a55fb1e89bb21d79 (patch)
treee59f4dcdc15e57510e35816da4534396c71c391d
parent986db08617b426c8f16bc3e8f06de11e3d450f65 (diff)
downloadaur-85df6b4b9c8b9b0390e79331a55fb1e89bb21d79.tar.gz
zdoom-2.8.1-4
* Build without fmodex by default * Make openal dependency optional * Make fluidsynth dependency optional * Add missing timidity++ optional dependency * Split freedoom optdepend to freedm, freedoom1, freedoom2 * Rename kdebase-kdialog optdepend to kdialog * Remove IWAD symlinks, as they are no longer functional
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD56
2 files changed, 32 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f5fa5819463a..28c6af94b87c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = zdoom
pkgdesc = Advanced Doom source port
pkgver = 2.8.1
- pkgrel = 3
+ pkgrel = 4
url = http://www.zdoom.org/
arch = i686
arch = x86_64
@@ -12,29 +12,33 @@ pkgbase = zdoom
license = LGPL
makedepends = cmake
makedepends = desktop-file-utils
+ makedepends = fluidsynth
makedepends = imagemagick
+ makedepends = openal
makedepends = p7zip
makedepends = xdg-utils
- depends = fluidsynth
- depends = fmodex=4.44.62
depends = gtk2
depends = libgme
depends = libsndfile
depends = mpg123
- depends = openal
depends = sdl2
optdepends = blasphemer-wad: Blasphemer (free Heretic) game data
optdepends = chexquest3-wad: Chex Quest 3 game data
optdepends = doom1-wad: Doom shareware game data
- optdepends = freedoom: FreeDoom game data
+ optdepends = fluidsynth: FluidSynth MIDI device
+ optdepends = freedm: FreeDM game data
+ optdepends = freedoom1: Freedoom: Phase 1 game data
+ optdepends = freedoom2: Freedoom: Phase 2 game data
optdepends = gxmessage: crash dialog (GNOME)
optdepends = hacx-wad: HacX game data
optdepends = harmony-wad: Harmony game data
optdepends = heretic1-wad: Heretic shareware game data
optdepends = hexen1-wad: Hexen demo game data
- optdepends = kdebase-kdialog: crash dialog (KDE)
+ optdepends = kdialog: crash dialog (KDE)
+ optdepends = openal: OpenAL sound backend
optdepends = strife0-wad: Strife shareware game data
optdepends = square1-wad: The Adventures of Square, Episode 1 game data
+ optdepends = timidity++: Timidity MIDI device
optdepends = urbanbrawl-wad: Urban Brawl: Action Doom 2 game data
optdepends = xorg-xmessage: crash dialog (other)
noextract = zdoom-2.8.1-src.7z
diff --git a/PKGBUILD b/PKGBUILD
index 1f4bc79ef9cd..2e4b1018e4c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,73 +1,72 @@
# Maintainer: Jan Cholasta <grubber at grubber cz>
# Contributor: Andrew Rabert <arabert@nullsum.net>
-# Build with fmodex:
-_fmodex=fmodex
# Build without fmodex:
-#_fmodex=
-
-# Build with OpenAL:
-_openal=openal
-# Build without OpenAL:
-#_openal=
+_fmodex=
+# Build with fmodex:
+#_fmodex=fmodex
_name=zdoom
pkgname=${_name}
pkgver=2.8.1
-pkgrel=3
+pkgrel=4
pkgdesc='Advanced Doom source port'
arch=('i686' 'x86_64')
url='http://www.zdoom.org/'
license=('BSD' 'custom:BUILD' 'custom:doom' 'custom:dumb' 'LGPL')
-depends=('fluidsynth'
- ${_fmodex:+$(LC_ALL=C pacman -Q $_fmodex | sed -r 's/ /=/;s/-.*$//')}
+depends=(${_fmodex:+$(LC_ALL=C pacman -Q $_fmodex | sed -r 's/ /=/;s/-.*$//')}
'gtk2'
'libgme'
- ${_openal:+'libsndfile'}
- ${_openal:+'mpg123'}
- ${_openal}
+ 'libsndfile'
+ 'mpg123'
'sdl2')
makedepends=('cmake'
'desktop-file-utils'
+ 'fluidsynth'
'imagemagick'
+ 'openal'
'p7zip'
'xdg-utils')
makedepends_i686=('nasm')
optdepends=('blasphemer-wad: Blasphemer (free Heretic) game data'
'chexquest3-wad: Chex Quest 3 game data'
'doom1-wad: Doom shareware game data'
- 'freedoom: FreeDoom game data'
+ 'fluidsynth: FluidSynth MIDI device'
+ 'freedm: FreeDM game data'
+ 'freedoom1: Freedoom: Phase 1 game data'
+ 'freedoom2: Freedoom: Phase 2 game data'
'gxmessage: crash dialog (GNOME)'
'hacx-wad: HacX game data'
'harmony-wad: Harmony game data'
'heretic1-wad: Heretic shareware game data'
'hexen1-wad: Hexen demo game data'
- 'kdebase-kdialog: crash dialog (KDE)'
+ 'kdialog: crash dialog (KDE)'
+ 'openal: OpenAL sound backend'
'strife0-wad: Strife shareware game data'
'square1-wad: The Adventures of Square, Episode 1 game data'
+ 'timidity++: Timidity MIDI device'
'urbanbrawl-wad: Urban Brawl: Action Doom 2 game data'
'xorg-xmessage: crash dialog (other)')
source=("http://zdoom.org/files/${_name}/${pkgver%.${pkgver#*.*.}}/${_name}-${pkgver}-src.7z"
'launcher.desktop'
'0001-Improve-Mac-GCC-errors-fix-to-work-only-for-GCC.patch')
noextract=("${source[0]##*/}")
-_srcsubdir='.'
sha256sums=('782179d4667d2e56e26e21d7a0872523f8e4262ed176072fef00d0043376a310'
'e8932a559baf30ecbfc062546ca014c6dfb70f76d1570549654209d39157e350'
'3de616393fa2eea8540c59c983a4394b29a0a0220095297a3f47e4f721b8d9fb')
prepare() {
- 7z x -y "${source[0]##*/}" >/dev/null
+ 7z x -o${_name} -y "${source[0]##*/}" >/dev/null
- cd "${_srcsubdir}"
+ cd $_name
- patch -p 1 -i 0001-Improve-Mac-GCC-errors-fix-to-work-only-for-GCC.patch
+ patch -p 1 -i "$srcdir"/0001-Improve-Mac-GCC-errors-fix-to-work-only-for-GCC.patch
}
build() {
- cd "${_srcsubdir}"
+ cd $_name
- local _nofmod _noopenal _fmodincdir _fmodlib
+ local _nofmod _fmodincdir _fmodlib
if [[ -n "${_fmodex}" ]]; then
_nofmod=OFF
@@ -77,14 +76,7 @@ build() {
_nofmod=ON
fi
- if [[ -n "${_openal}" ]]; then
- _noopenal=OFF
- else
- _noopenal=ON
- fi
-
cmake -DNO_FMOD=${_nofmod} \
- -DNO_OPENAL=${_noopenal} \
-DGME_INCLUDE_DIR='/usr/include/gme' \
-DFMOD_INCLUDE_DIR="${_fmodincdir}" \
-DFMOD_LIBRARY="${_fmodlib}" \
@@ -111,7 +103,7 @@ EOF
}
package() {
- cd "${_srcsubdir}"
+ cd $_name
install -D "${_name}.sh" "${pkgdir}/usr/bin/${_name}"
@@ -121,10 +113,6 @@ package() {
if [[ -n "${_fmodex}" ]]; then
install 'liboutput_sdl.so' "${pkgdir}/usr/lib/${_name}/"
fi
- ln -s '/usr/share/doom/doom.wad' "${pkgdir}/usr/lib/${_name}/freedoomu.wad"
- ln -s '/usr/share/doom/doom2.wad' "${pkgdir}/usr/lib/${_name}/freedoom.wad"
- ln -s '/usr/share/doom/heretic.wad' "${pkgdir}/usr/lib/${_name}/blasphemer.wad"
- ln -s '/usr/share/doom/hexen.wad' "${pkgdir}/usr/lib/${_name}/hexendemo.wad"
mkdir -p "${pkgdir}/usr/share/${_name}"