summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Cholasta2016-12-27 18:38:46 +0100
committerJan Cholasta2016-12-27 20:39:35 +0100
commit1d4f2b53dffa284b8137dc4040952261e76862ed (patch)
tree256241c5b6ff7ff89255b6c20b0d3efe2958c7ec
parent2bf34393c889bcc008f3752689106b1d54e98081 (diff)
downloadaur-1d4f2b53dffa284b8137dc4040952261e76862ed.tar.gz
zdoom-git-2.9pre.2174.g625e97dfd
* Build with the last fmodex version by default * nasm is no longer required
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD28
2 files changed, 11 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b1de69c767fb..88edfed8fefe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = zdoom-git
pkgdesc = Advanced Doom source port (git version)
- pkgver = 2.9pre.982.g34c67b9
+ pkgver = 2.9pre.2174.g625e97dfd
pkgrel = 1
url = http://www.zdoom.org/
arch = i686
@@ -16,7 +16,7 @@ pkgbase = zdoom-git
makedepends = imagemagick
makedepends = xdg-utils
depends = fluidsynth
- depends = fmodex4.26.36
+ depends = fmodex=4.44.62
depends = gtk2
depends = libgme
depends = libsndfile
@@ -43,7 +43,6 @@ pkgbase = zdoom-git
source = launcher.desktop
sha256sums = SKIP
sha256sums = e8932a559baf30ecbfc062546ca014c6dfb70f76d1570549654209d39157e350
- makedepends_i686 = nasm
pkgname = zdoom-git
diff --git a/PKGBUILD b/PKGBUILD
index 20dbe2718eea..33cbd76bb6cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,7 @@
# Maintainer: Jan Cholasta <grubber at grubber cz>
-# Build with the recommended fmodex version:
-_fmodex=fmodex4.26.36
-# Build with the currently installed fmodex version:
-#_fmodex=$(LC_ALL=C pacman -Q fmodex | sed -r 's/ /=/;s/-.*$//')
+# Build with fmodex:
+_fmodex=fmodex
# Build without fmodex:
#_fmodex=
@@ -14,16 +12,14 @@ _openal=openal
_name=zdoom
pkgname=${_name}-git
-pkgver=2.9pre.982.g34c67b9
+pkgver=2.9pre.2174.g625e97dfd
pkgrel=1
-_label='ZDoom'
-_desc='Advanced Doom source port'
-pkgdesc="${_desc} (git version)"
+pkgdesc='Advanced Doom source port (git version)'
arch=('i686' 'x86_64')
url='http://www.zdoom.org/'
license=('BSD' 'custom:BUILD' 'custom:doom' 'custom:dumb' 'LGPL')
depends=('fluidsynth'
- ${_fmodex}
+ ${_fmodex:+$(LC_ALL=C pacman -Q $_fmodex | sed -r 's/ /=/;s/-.*$//')}
'gtk2'
'libgme'
${_openal:+'libsndfile'}
@@ -35,7 +31,6 @@ makedepends=('cmake'
'git'
'imagemagick'
'xdg-utils')
-makedepends_i686=('nasm')
optdepends=('blasphemer-wad: Blasphemer (free Heretic) game data'
'chexquest3-wad: Chex Quest 3 game data'
'doom1-wad: Doom shareware game data'
@@ -64,15 +59,15 @@ pkgver() {
git describe --long --tags | sed -r 's/([^-]*-g)/\1/;s/-/./g'
}
-prepare() {
+build() {
cd "${_srcsubdir}"
local _nofmod _noopenal _fmodincdir _fmodlib
if [[ -n "${_fmodex}" ]]; then
_nofmod=OFF
- _fmodincdir=$(LC_ALL=C pacman -Ql ${_fmodex%=*} | grep -Eo '/usr/include/fmodex[^/]*/$')
- _fmodlib=$(LC_ALL=C pacman -Ql ${_fmodex%=*} | grep -Eo '/usr/lib/libfmodex-[^/]*\.so$')
+ _fmodincdir=$(LC_ALL=C pacman -Ql $_fmodex | grep -Eo '/usr/include/fmodex[^/]*/$')
+ _fmodlib=$(LC_ALL=C pacman -Ql $_fmodex | grep -Eo '/usr/lib/libfmodex-[^/]*\.so$')
else
_nofmod=ON
fi
@@ -93,18 +88,13 @@ prepare() {
-DCMAKE_CXX_FLAGS="$CXXFLAGS -DSHARE_DIR=\\\"/usr/share/${_name}\\\"" \
-DCMAKE_EXE_LINKER_FLAGS="$LDFLAGS -Wl,-z,noexecstack" \
.
-}
-
-build() {
- cd "${_srcsubdir}"
+ make
cat >"${_name}.sh" <<EOF
#!/bin/sh
exec /usr/lib/${_name}/${_name} "\$@"
EOF
- make
-
sed -n '/\*\*-/,/\*\*-/p' 'src/version.h' >'bsd.txt'
cp "${srcdir}/launcher.desktop" "${_name}.desktop"