summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Cholasta2014-09-11 23:46:47 +0200
committerJan Cholasta2014-09-24 23:03:49 +0200
commit64307213677042dbd6f042ceafec833462ccdfe6 (patch)
tree5ae67b9227e3f6441999b76b1a47b04e4018769e
parent3f11f9fcaea874c71a1bc03171bf5d7e9c8f7711 (diff)
downloadaur-64307213677042dbd6f042ceafec833462ccdfe6.tar.gz
Use fmodex4.26.36 for libfmodex in *zdoom* packages
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD35
2 files changed, 5 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6abb5088db36..ff78143b23dc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,6 +11,7 @@ pkgbase = zdoom-git
makedepends = git
makedepends = imagemagick
depends = fluidsynth
+ depends = fmodex4.26.36
depends = gtk2
depends = gxmessage
depends = sdl
@@ -27,12 +28,10 @@ pkgbase = zdoom-git
provides = zdoom
conflicts = zdoom
source = zdoom::git://github.com/rheit/zdoom.git
- source = http://www.fmod.org/download/fmodex/api/Linux/fmodapi42636linux.tar.gz
source = doom-share-dir.patch
source = stack-noexec.patch
source = zdoom.desktop
md5sums = SKIP
- md5sums = 220a54f330bdf3056d6207a0facf2096
md5sums = c8a3905f172f6d9de548e70fa660a300
md5sums = e1e1160df8dcf969d9acae76dab27bed
md5sums = 83e47fdae2768da78cd4ac151ec92ad1
diff --git a/PKGBUILD b/PKGBUILD
index 500685942ddf..4863695d25da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,5 @@
# Maintainer: Jan Cholasta <grubber at grubber cz>
-_fmodver=42636
-_fmodarch=linux
-if [[ "$CARCH" == x86_64 ]]; then
- _fmodarch=linux64
-fi
-
pkgname=zdoom-git
pkgver=2.8pre.r636.g79d9a57
pkgrel=1
@@ -13,7 +7,7 @@ pkgdesc="An enhanced Doom port with additional support for Heretic, Hexen and St
arch=('i686' 'x86_64')
url="http://www.zdoom.org/"
license=('custom')
-depends=('fluidsynth' 'gtk2' 'gxmessage' 'sdl')
+depends=('fluidsynth' 'fmodex4.26.36' 'gtk2' 'gxmessage' 'sdl')
makedepends=('nasm' 'cmake' 'git' 'imagemagick')
optdepends=('blasphemer: Blasphemer (free Heretic) game data'
'chexquest3-wad: Chex Quest 3 game data'
@@ -28,22 +22,15 @@ optdepends=('blasphemer: Blasphemer (free Heretic) game data'
provides=('zdoom')
conflicts=('zdoom')
source=(zdoom::git://github.com/rheit/zdoom.git \
- http://www.fmod.org/download/fmodex/api/Linux/fmodapi${_fmodver}${_fmodarch}.tar.gz \
doom-share-dir.patch \
stack-noexec.patch \
zdoom.desktop)
md5sums=('SKIP'
- '220a54f330bdf3056d6207a0facf2096'
'c8a3905f172f6d9de548e70fa660a300'
'e1e1160df8dcf969d9acae76dab27bed'
'83e47fdae2768da78cd4ac151ec92ad1')
-if [[ "$CARCH" == i?86 ]]; then
- md5sums[1]='220a54f330bdf3056d6207a0facf2096'
-elif [[ "$CARCH" == x86_64 ]]; then
- md5sums[1]='355cba00a34eb5f7d027da68b452f6d9'
-fi
-
+_fmodver=4.26.36
_libdir=/usr/lib/zdoom
_sharedir=/usr/share/games/zdoom
@@ -64,22 +51,10 @@ prepare() {
build() {
cd zdoom
- local _fmodlib
- if [[ "$CARCH" == i?86 ]]; then
- _fmodlib=libfmodex-${_fmodver:0:1}.${_fmodver:1:2}.${_fmodver:3:2}.so
- elif [[ "$CARCH" == x86_64 ]]; then
- _fmodlib=libfmodex64-${_fmodver:0:1}.${_fmodver:1:2}.${_fmodver:3:2}.so
- fi
-
- cp "$srcdir/fmodapi${_fmodver}${_fmodarch}/api/lib/$_fmodlib" libfmodex.so
-
- cmake -DFMOD_INCLUDE_DIR="$srcdir/fmodapi${_fmodver}${_fmodarch}/api/inc" \
- -DFMOD_LIBRARY=libfmodex.so \
+ cmake -DFMOD_INCLUDE_DIR=/usr/include/fmodex-$_fmodver \
+ -DFMOD_LIBRARY=/usr/lib/libfmodex-$_fmodver.so \
-DCMAKE_C_FLAGS="$CFLAGS -DSHARE_DIR=\\\"$_sharedir\\\"" \
-DCMAKE_CXX_FLAGS="$CXXFLAGS -DSHARE_DIR=\\\"$_sharedir\\\"" \
- -DCMAKE_INSTALL_RPATH=$_libdir \
- -DCMAKE_BUILD_WITH_INSTALL_RPATH=1 \
- -DCMAKE_SKIP_BUILD_RPATH=1 \
.
make
@@ -89,8 +64,6 @@ build() {
package() {
cd zdoom
- install -Dm755 libfmodex.so "$pkgdir/$_libdir/libfmodex.so"
-
install -Dm755 zdoom "$pkgdir/usr/bin/zdoom"
install -Dm755 liboutput_sdl.so "$pkgdir/$_libdir/liboutput_sdl.so"
install -Dm644 zdoom.pk3 "$pkgdir/$_sharedir/zdoom.pk3"