summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorint2022-05-19 10:09:25 +0200
committerint2022-05-19 10:29:17 +0200
commit2cb91bee8c9989eb8ab36d2d7324933750e88f1a (patch)
treef6071f8e94a61b73b7ac369140d76c84ca85cc17
parent46da5d860433ff7af52959ef4abdec52f0d4159e (diff)
downloadaur-2cb91bee8c9989eb8ab36d2d7324933750e88f1a.tar.gz
Version bump and some corrections.
Most notably a test fails with libxslt 1.1.35, so version 1.1.34 or below of it is requested in the dependencies.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD25
2 files changed, 13 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca85f7bb3f18..323da4ccf2a1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = zebra
pkgdesc = A high-performance, general-purpose structured text indexing and retrieval engine.
- pkgver = 2.1.4
+ pkgver = 2.2.3
pkgrel = 1
url = http://www.indexdata.com/zebra/
arch = i686
@@ -10,9 +10,9 @@ pkgbase = zebra
depends = expat
depends = perl
depends = yaz>=3.0.47
- depends = zlib
- source = http://ftp.indexdata.dk/pub/zebra/idzebra-2.1.4.tar.gz
- sha512sums = da5d473e504acb8dc90c02e36560b48477e331fb9480cff5dc322a7f27344a933d80f2559978bb860cb8225559ad5eed5597beaa4f3b5deb6b4a7672ab607a99
+ depends = libxslt<=1.1.34
+ depends = tcl
+ source = http://ftp.indexdata.dk/pub/zebra/idzebra-2.2.3.tar.gz
+ sha512sums = c2c55c7883e73277615dd65488fae5f3c00a9fed017e619ce278e68787e87ef7ef349c0a55e4b1e9c572e7114b0dc0a230ac31895220ce3c01b0e356660a53fd
pkgname = zebra
-
diff --git a/PKGBUILD b/PKGBUILD
index a65bd4637283..84ddcfb0a1f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,19 @@
# Maintainer: int <int [ate] arcor [dot] de>
#
-# NOTE: idzebra-config-2.0 contains the path of $srcdir, where the package is build.
-# So makepkg warns: "WARNING: Package contains reference to $srcdir" during package-build,
-# see https://wiki.archlinux.org/index.php/makepkg#WARNING:_Package_contains_reference_to_.24srcdir.
-# But this values are only used in a dead if-branch in idzebra-config-2.0,
-# so just ignore the warning.
-# (The values are only used if $echo_source in idzebra-config-2.0 is set to "yes".
-# But this variable is set to "no" in the script, so this if-branch is dead.)
-#
-# Two possibilities: ignore the warning or patch this dead if-branch out of the script.
-# I decided to ignore it for now.
+# NOTE: A test fails with libxslt version 1.1.35.
+# So when using this package downgrade and pin libxslt to a previous version.
#
pkgname=zebra
_dlname=idzebra
-pkgver=2.1.4
+pkgver=2.2.3
pkgrel=1
pkgdesc="A high-performance, general-purpose structured text indexing and retrieval engine."
arch=('i686' 'x86_64')
url="http://www.indexdata.com/zebra/"
license=('GPL')
-depends=('bzip2' 'expat' 'perl' 'yaz>=3.0.47' 'zlib')
+depends=('bzip2' 'expat' 'perl' 'yaz>=3.0.47' 'libxslt<=1.1.34' 'tcl')
source=("http://ftp.indexdata.dk/pub/zebra/${_dlname}-${pkgver}.tar.gz")
-sha512sums=('da5d473e504acb8dc90c02e36560b48477e331fb9480cff5dc322a7f27344a933d80f2559978bb860cb8225559ad5eed5597beaa4f3b5deb6b4a7672ab607a99')
+sha512sums=('c2c55c7883e73277615dd65488fae5f3c00a9fed017e619ce278e68787e87ef7ef349c0a55e4b1e9c572e7114b0dc0a230ac31895220ce3c01b0e356660a53fd')
prepare() {
cd "$_dlname-$pkgver"
@@ -30,12 +22,11 @@ prepare() {
build() {
cd "$_dlname-$pkgver"
- # --with-yaz wants the path to yaz-config
+ # --with-yaz=pkg means use pkgconfig instead of yaz-config
./configure --prefix=/usr \
- --with-yaz=/usr/bin \
+ --with-yaz=pkg \
--without-docbook-dtd --without-docbook-dsssl --without-docbook-xsl \
- --without-tclconfig \
- --with-iconv --with-expat
+ --with-iconv
make
}