summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2024-04-02 14:03:39 +0300
committerCaleb Maclennan2024-04-02 14:03:39 +0300
commit380e5be20fb2b82d46942fbef0e1aa7592bd20ca (patch)
tree8b2d400b234edd91394702ad53541a73f4194ad0
parente5881c08588c437e91737a96130dd1d2988cd60b (diff)
downloadaur-380e5be20fb2b82d46942fbef0e1aa7592bd20ca.tar.gz
upgpkg: zed-editor-git 0.61.0.r12598.g1dbd520-1
Add desktop file
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
2 files changed, 18 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0864b2867fc4..7ccfedd20e95 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = zed-editor-git
- pkgdesc = high-performance, multiplayer code editor from the creators of Atom and Tree-sitter
- pkgver = 0.61.0.r12398.g59bc81d
+ pkgdesc = A high-performance, multiplayer code editor from the creators of Atom and Tree-sitter
+ pkgver = 0.61.0.r12598.g1dbd520
pkgrel = 1
url = https://zed.dev
arch = x86_64
@@ -8,6 +8,7 @@ pkgbase = zed-editor-git
license = AGPL-3.0-or-later
license = Apache-2.0
makedepends = cargo
+ makedepends = gendesk
makedepends = git
makedepends = vulkan-headers
makedepends = vulkan-validation-layers
@@ -16,13 +17,7 @@ pkgbase = zed-editor-git
depends = fontconfig
depends = gcc-libs
depends = glibc
- depends = libgit2
- depends = libgit2.so
- depends = libxau
- depends = libXau.so
depends = libxcb
- depends = libxdmcp
- depends = libXdmcp.so
depends = libxkbcommon
depends = libxkbcommon-x11
depends = openssl
@@ -35,7 +30,7 @@ pkgbase = zed-editor-git
depends = wayland
depends = zlib
depends = libz.so
- provides = zed-editor=0.61.0.r12398.g59bc81d
+ provides = zed-editor=0.61.0.r12598.g1dbd520
conflicts = zed-editor
source = zed-editor-git::git+https://github.com/zed-industries/zed.git
source = https://github.com/livekit/protocol/archive/8645a138fb2ea72c4dab13e739b1f3c9ea29ac84/protocol-8645a138fb2ea72c4dab13e739b1f3c9ea29ac84.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index f09a89df90bf..51e10ce509ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,9 +12,9 @@ declare -gA _tags=(
BUILDENV+=(!check)
pkgname=zed-editor-git
-pkgver=0.61.0.r12398.g59bc81d
+pkgver=0.61.0.r12598.g1dbd520
pkgrel=1
-pkgdesc='high-performance, multiplayer code editor from the creators of Atom and Tree-sitter'
+pkgdesc='A high-performance, multiplayer code editor from the creators of Atom and Tree-sitter'
arch=(x86_64)
url=https://zed.dev
_url="https://github.com/zed-industries/zed"
@@ -23,10 +23,10 @@ depends=(alsa-lib libasound.so
fontconfig
gcc-libs # libgcc_s.so libstdc++.so
glibc # libc.so libm.so
- libgit2 libgit2.so
- libxau libXau.so
+ # libgit2 libgit2.so
+ # libxau libXau.so
libxcb # libxcb-xkb.so
- libxdmcp libXdmcp.so
+ # libxdmcp libXdmcp.so
libxkbcommon # libxkbcommon.so
libxkbcommon-x11 # libxkbcommon-x11.so
openssl libcrypto.so libssl.so
@@ -37,6 +37,7 @@ depends=(alsa-lib libasound.so
wayland
zlib libz.so)
makedepends=(cargo
+ gendesk
git
vulkan-headers
vulkan-validation-layers)
@@ -52,6 +53,12 @@ prepare() {
rm -r crates/live_kit_server/protocol
ln -sT "$srcdir/protocol-${_tags[protocol]}" crates/live_kit_server/protocol
cargo fetch --locked --target "$(rustc -vV | sed -n 's/host: //p')"
+ gendesk -q -f -n \
+ --name 'Zed' \
+ --exec 'Zed' \
+ --pkgname "${pkgname%-git}" \
+ --pkgdesc "$pkgdesc" \
+ --categories 'Office'
}
pkgver() {
@@ -81,4 +88,6 @@ check() {
package() {
cd "$pkgname"
install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/Zed"
+ install -Dm0644 -t "$pkgdir/usr/share/applications/" "${pkgname%-git}.desktop"
+ install -Dm0644 crates/zed/resources/app-icon.png "$pkgdir/usr/share/icons/${pkgname%-git}.png"
}