summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMickael Bosch2016-08-09 21:39:04 +0200
committerMickael Bosch2016-08-09 21:39:04 +0200
commit1c5cbbfce802a37257e90ce6ad4b014b4c499e06 (patch)
tree147d92e8357e2bdfb4326bc6b8c606710287de2a
downloadaur-1c5cbbfce802a37257e90ce6ad4b014b4c499e06.tar.gz
create the ZeGrapher Arch package
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d792af62ff88
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = zegrapher
+ pkgdesc = mathematical objects plotting software
+ pkgver = 3.0.0
+ pkgrel = 1
+ url = http://www.zegrapher.com
+ arch = x86_64
+ arch = i686
+ license = GPL
+ depends = qt5-base
+ conflicts = zegrapher
+ source = https://github.com/AdelKS/ZeGrapher/archive/v3.0.zip
+ md5sums = 82cc38fa4904f1a506038462398c6e3d
+
+pkgname = zegrapher
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7498c34c2733
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+ # Maintainer: Mickael Bosch <mickael dot bosch at hl2 dot com>
+pkgname='zegrapher'
+pkgver=3.0.0
+pkgrel=1
+arch=('x86_64' 'i686')
+url="http://www.zegrapher.com"
+makedepends=()
+license=('GPL')
+pkgdesc="mathematical objects plotting software"
+depends=(qt5-base)
+conflicts=(zegrapher)
+source=("https://github.com/AdelKS/ZeGrapher/archive/v3.0.zip")
+md5sums=('82cc38fa4904f1a506038462398c6e3d')
+
+build() {
+ cd "ZeGrapher-3.0"
+ qmake
+ make
+}
+
+package() {
+ cd "ZeGrapher-3.0"
+ install -Dm755 ZeGrapher "$pkgdir"/usr/bin/ZeGrapher
+ install -Dm644 appicon.ico "$pkgdir"/usr/share/pixmaps/ZeGrapher.ico
+}