summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-10-15 09:48:36 +1300
committercaltlgin2020-10-15 09:48:36 +1300
commit80c7f9af3d058039662019978e1b8c5907b8a53a (patch)
tree07eaf2bb424698f69f6f5eb55e3e2470c49eb0c4
downloadaur-80c7f9af3d058039662019978e1b8c5907b8a53a.tar.gz
Add to AUR
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD37
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7491e18fef46
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = zeit-git
+ pkgdesc = Qt frontend to at and crontab CLI utilities
+ pkgver = 0.5.0.r13.g8ee712b
+ pkgrel = 1
+ url = https://github.com/loimu/zeit
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ makedepends = cron
+ makedepends = git
+ depends = kauth
+ provides = zeit
+ conflicts = zeit
+ source = zeit::git+https://github.com/loimu/zeit.git
+ sha256sums = SKIP
+
+pkgname = zeit-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..80d7aab4754b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+_pkgname='zeit'
+pkgname="${_pkgname}-git"
+pkgver=0.5.0.r13.g8ee712b
+pkgrel=1
+pkgdesc='Qt frontend to at and crontab CLI utilities'
+arch=('x86_64')
+url='https://github.com/loimu/zeit'
+license=('GPL3')
+depends=('kauth')
+makedepends=('cmake' 'cron' 'git')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("${_pkgname}::git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ git -C "${_pkgname}" describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ export CFLAGS+=" ${CPPFLAGS}"
+ export CXXFLAGS+=" ${CPPFLAGS}"
+ cmake -B 'build' -S "${_pkgname}" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -Wno-dev
+ make -C 'build'
+}
+
+package() {
+ make DESTDIR="${pkgdir}" PREFIX='/usr' -C 'build' install
+ install -Dvm644 "${_pkgname}/Readme.md" -t "${pkgdir}/usr/share/doc/${_pkgname}"
+}
+
+# vim: ts=2 sw=2 et: