summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSemyon Maryasin2019-08-13 00:04:58 +0300
committerSemyon Maryasin2019-08-13 00:08:28 +0300
commit268fcc29163860557ad0e3be620a3af9d92910bd (patch)
treef591af0ab5aeed873604f0ba9672a01255f77cf1
parent2f405a7459239473f7a8200eb7485ec392cbe518 (diff)
downloadaur-268fcc29163860557ad0e3be620a3af9d92910bd.tar.gz
Pin back to latest version which included binary bundle
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD27
2 files changed, 10 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be1cda332c0f..b5591950fd01 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = zeit-now-bin
- pkgdesc = Realtime Global Deployments by Zeit, pre-built binary (always latest version)
- pkgver = 14.0.3
+ pkgdesc = Realtime Global Deployments by Zeit, pre-built binary (outdated)
+ pkgver = 15.8.7
pkgrel = 1
url = https://zeit.co/now
arch = x86_64
@@ -10,8 +10,8 @@ pkgbase = zeit-now-bin
provides = zeit-now
conflicts = nodejs-now
options = !strip
- source = https://api.github.com/repos/zeit/now-cli/releases/latest
- md5sums = SKIP
+ source = https://github.com/zeit/now-cli/releases/download/15.8.7/now-linux.gz
+ md5sums = cb106ea0f55d81877cd2368168da9678
pkgname = zeit-now-bin
diff --git a/PKGBUILD b/PKGBUILD
index 6297e434c59b..b07213c32321 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,10 +5,10 @@
# Maintainer: Your Name <youremail@domain.com>
pkgname=zeit-now-bin
-pkgver=14.0.3
+pkgver=15.8.7
pkgrel=1
epoch=
-pkgdesc="Realtime Global Deployments by Zeit, pre-built binary (always latest version)"
+pkgdesc="Realtime Global Deployments by Zeit, pre-built binary (outdated)"
arch=("x86_64")
url="https://zeit.co/now"
# license is according to https://www.npmjs.com/package/now
@@ -25,29 +25,14 @@ backup=()
options=("!strip")
install=
changelog=
-# Actually this is just an information about the latest version.
-source=("https://api.github.com/repos/zeit/now-cli/releases/latest")
+source=("https://github.com/zeit/now-cli/releases/download/${pkgver}/now-linux.gz")
noextract=()
-md5sums=('SKIP')
+md5sums=('cb106ea0f55d81877cd2368168da9678')
validpgpkeys=()
-pkgver() {
- # Could not find a way to check version *before* downloading sources,
- # so we fetch version information instead of sources
- # and then download the real binary in build().
- # The data in `latest` is a pretty-printed JSON.
- # We could parse it using `jq` package, but let's not introduce extra dependencies
- # for such trivial case.
- # FIXME: sometimes we get an HTML page in the `latest` file,
- # despite it should be JSON.
- cat latest | grep -Po '(?<="tag_name":)\s*"[0-9.]*"' | tr -d '" '
-}
-
build() {
- # now really download the source
- curl -L https://github.com/zeit/now-cli/releases/download/${pkgver}/now-linux.gz -o now-linux.gz
- # and unpack it
- gunzip now-linux.gz
+ # XXX why is this required? It was not required before auto-update
+ gunzip < now-linux.gz > now-linux
chmod +x now-linux
}