summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSemyon Maryasin2018-04-08 02:45:32 +0300
committerSemyon Maryasin2018-04-08 02:45:32 +0300
commit2be0d57018609613dbd8e96631843fe43e46ae9d (patch)
tree1b7613d1d78e32b12b8654ff8e12110dcabc20a9
downloadaur-2be0d57018609613dbd8e96631843fe43e46ae9d.tar.gz
First variant (working)
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD38
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ed5984fe5900
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = zeit-now-bin
+ pkgdesc = Realtime Global Deployments by Zeit, pre-built binary
+ pkgver = 11.0.6
+ pkgrel = 1
+ url = https://zeit.co/now
+ arch = x86_64
+ license = custom
+ makedepends = gzip
+ depends = glibc
+ provides = zeit-now
+ conflicts = nodejs-now
+ source = https://github.com/zeit/now-cli/releases/download/11.0.6/now-linux.gz
+ md5sums = bfdd9ff3926982c046168a647de25829
+
+pkgname = zeit-now-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..55617675357e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=zeit-now-bin
+pkgver=11.0.6
+pkgrel=1
+epoch=
+pkgdesc="Realtime Global Deployments by Zeit, pre-built binary"
+arch=("x86_64")
+url="https://zeit.co/now"
+license=("custom")
+groups=()
+depends=("glibc")
+makedepends=("gzip")
+checkdepends=()
+optdepends=()
+provides=("zeit-now")
+conflicts=("nodejs-now")
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/zeit/now-cli/releases/download/${pkgver}/now-linux.gz")
+noextract=()
+md5sums=('bfdd9ff3926982c046168a647de25829')
+validpgpkeys=()
+
+build() {
+ chmod +x now-linux
+}
+
+package() {
+ install -D now-linux "${pkgdir}/usr/bin/now"
+}