summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYannick Lange2015-01-08 18:33:13 +0100
committerYannick Lange2015-01-08 18:33:13 +0100
commit02af02ffe930315c2d746d7f9e570d3aaff6061e (patch)
tree35538b0a18401f8777498fcdf7582d3487e81b5d
downloadaur-02af02ffe930315c2d746d7f9e570d3aaff6061e.tar.gz
Initial commit for 1.8-4
-rw-r--r--.SRCINFO28
-rw-r--r--ChangeLog21
-rw-r--r--PKGBUILD71
-rw-r--r--zelda-3t.desktop11
-rw-r--r--zelda-3t.install18
5 files changed, 149 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aa4d0a170975
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+# Generated by makepkg 4.2.0
+# Thu Jan 8 17:31:39 UTC 2015
+pkgbase = zelda-3t-fr
+ pkgdesc = Zelda: Time To Triumph (french version)
+ pkgver = 1.8
+ pkgrel = 4
+ url = http://www.zeldaroth.fr/
+ install = zelda-3t.install
+ changelog = ChangeLog
+ arch = i686
+ arch = x86_64
+ license = Unknown
+ makedepends = imagemagick
+ depends = sdl_gfx
+ depends = sdl_mixer
+ depends = sdl_image
+ depends = xdg-utils
+ depends = hicolor-icon-theme
+ depends = timidity++
+ optdepends = timidity-freepats: soundfont for timidity to be able to have music in game
+ optdepends = fluidr3: another soundfont for timidity to be able to have music in game if you prefer
+ source = http://www.zeldaroth.fr/fichier/3T/linux/Zelda3T-src-linux.zip
+ source = zelda-3t.desktop
+ md5sums = f1d24ec72bff3413cfc1e835ef4703da
+ md5sums = ab544512c46a87f6ef62ae6cdea794fc
+
+pkgname = zelda-3t-fr
+
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 000000000000..a5d5334bd8cb
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,21 @@
+2013-02-28 FoolEcho <foolecho at gmail dot com>
+
+ * 1.8-4 :
+ Added prepare() (pacman 4.1).
+ Code presentation.
+
+ * 1.8-3 :
+ Added ChangeLog.
+ Patched the sources to save and restore the game settings (volumes and ranks ; not tested but ranks should be also accrued with ranks from Return of the Hylian and Oni Link Begins) in your HOME (with the saves).
+ Patched the sources to be able to remove old saves from the game menu.
+
+2013-02-26 FoolEcho <foolecho at gmail dot com>
+
+ * 1.8-2 :
+ Added timidity++ as dependency in order to have music in game (musics are .mid ; you need to install and configure a soundfont such as timidity-freepats or fluidr3);
+ Corrections of the PKGBUILD (.install)
+
+2013-02-14 FoolEcho <foolecho at gmail dot com>
+
+ * 1.8-1 :
+ First release (PKGBUILD initially based on zelda-roth-en and so on)
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..14861c6984ee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,71 @@
+# Maintainer: FoolEcho <foolecho at gmail dot com>
+pkgname=zelda-3t-fr
+_name=zelda-3t
+pkgver=1.8
+pkgrel=4
+arch=('i686' 'x86_64')
+pkgdesc="Zelda: Time To Triumph (french version)"
+url="http://www.zeldaroth.fr/"
+license=('Unknown')
+depends=('sdl_gfx' 'sdl_mixer' 'sdl_image' 'xdg-utils' 'hicolor-icon-theme' 'timidity++')
+makedepends=(imagemagick)
+optdepends=('timidity-freepats: soundfont for timidity to be able to have music in game'
+ 'fluidr3: another soundfont for timidity to be able to have music in game if you prefer')
+install=${_name}.install
+changelog=ChangeLog
+source=(
+ "http://www.zeldaroth.fr/fichier/3T/linux/Zelda3T-src-linux.zip"
+ zelda-3t.desktop)
+md5sums=('f1d24ec72bff3413cfc1e835ef4703da'
+ 'ab544512c46a87f6ef62ae6cdea794fc')
+
+prepare () {
+ cd $srcdir/Zelda3T-src-linux/
+
+ # Fix the Game so that it reads save files from $HOME/.zelda-3t
+ sed -i -e s~\"data/save/~string\(getenv\(\"HOME\"\)\)+\"/.$_name/~g Joueur.cpp
+ #save/restore volume settings and ranks
+ sed -i -e s#\"data/save/system.dat\"#\(string\(getenv\(\"HOME\"\)\)+\"/.$_name/system.dat\"\).c_str\(\)#g Keyboard.cpp
+ #remove saves from menu
+ sed -i -e s#\"data/save#string\(getenv\(\"HOME\"\)\)+\"/.$_name#g Keyboard.cpp
+ #grab rank from Zelda Return of the Hylian
+ sed -i -e s#Zelda\ Return\ of\ the\ Hylian/data/save#.zelda-roth#g Keyboard.cpp
+ #grab rank from Zelda Oni Link Begins
+ sed -i -e s#Zelda\ Oni\ Link\ Begins/data/save#.zelda-olb#g Keyboard.cpp
+
+ #Make the game treat /usr/share/$pkgname as its data directory
+ for i in *.cpp
+ do
+ sed -i -e s~data/~/usr/share/$pkgname/~g $i
+ done
+
+ # Create the directory $HOME/.zelda3t if it doesnt exist
+ sed -i -e s~'(NULL));'~'&\n\tif (system(\"stat $HOME/.'$_name' \&> /dev/null")) system (\"mkdir $HOME/.'$_name'\");'~ main.cpp
+}
+
+build () {
+ cd $srcdir/Zelda3T-src-linux/
+ make
+}
+
+package () {
+
+ install -Dm644 $_name.desktop $pkgdir/usr/share/applications/$_name.desktop
+ cd $srcdir/Zelda3T-src-linux/
+
+ install -Dm755 Zelda3T $pkgdir/usr/bin/$_name
+
+ cd data
+ for i in {map,music,sound}/*
+ do
+ install -Dm644 $i $pkgdir/usr/share/$pkgname/$i
+ done
+
+ cd images
+ for i in */*
+ do
+ install -Dm644 $i $pkgdir/usr/share/$pkgname/images/$i
+ done
+ mkdir -p $pkgdir/usr/share/icons/hicolor/256x256/apps
+ convert logos/fond.png -resize 256x256\! $pkgdir/usr/share/icons/hicolor/256x256/apps/$_name.png
+}
diff --git a/zelda-3t.desktop b/zelda-3t.desktop
new file mode 100644
index 000000000000..cc278cb226cc
--- /dev/null
+++ b/zelda-3t.desktop
@@ -0,0 +1,11 @@
+#!/usr/bin/env xdg-open
+[Desktop Entry]
+Name=Zelda3T
+GeneralName=Zelda: A Time to Triumph
+Comment=Third Game in a trilogy of fan made Zelda Games
+Comment[fr]=Troisième jeu dans une trilogie de jeu Zelda fait par des fans
+Exec=zelda-3t
+Icon=zelda-3t.png
+Terminal=false
+Type=Application
+Categories=Game
diff --git a/zelda-3t.install b/zelda-3t.install
new file mode 100644
index 000000000000..1363f01f17ba
--- /dev/null
+++ b/zelda-3t.install
@@ -0,0 +1,18 @@
+post_install() {
+ echo "update mime database..."
+ update-mime-database /usr/share/mime/ > /dev/null
+ echo "update desktop database..."
+ update-desktop-database -q
+ echo "update icon cache..."
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ echo ""
+ echo "Don't forget to install the package timidity-freepats or fluidr3 and configure /etc/timidity++/timidity.cfg in order to have music in game"
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+} \ No newline at end of file