summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcell Meszaros2022-04-09 21:32:52 +0200
committerMarcell Meszaros2022-04-09 21:32:52 +0200
commit967c922be20b671865afac68a2a080a9d0ccf424 (patch)
tree044e1996cf548958fa93bf10008c7cf11cd3973f
parenta126040c71dfd5ad8a9591f75c8d8d3d7a3ea285 (diff)
downloadaur-967c922be20b671865afac68a2a080a9d0ccf424.tar.gz
[fix] use official package, don't strip binaries, add bash depends, remove libxpm
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD12
3 files changed, 22 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7e5333de3045..3cc9ca877a8e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,14 @@
pkgbase = zelda-classic
pkgdesc = A tribute to Nintendo's The Legend of Zelda (NES)
pkgver = 2.50.2.29
- pkgrel = 1
+ pkgrel = 2
url = http://zeldaclassic.com
install = zelda-classic.install
arch = i686
arch = x86_64
license = custom: Freeware
- depends = lib32-libxpm
- depends = lib32-libxxf86vm
- depends = lib32-libxcursor
- depends = lib32-alsa-lib
- optdepends = lib32-gtk-engine-murrine: needed for the gtk2-launcher
- source = https://www.dropbox.com/s/fnipdbanjm8bf2v/zc-2-50-2-linux.tar.gz
+ options = !strip
+ source = zelda-classic-2-50-2-linux.tar.gz::https://www.zeldaclassic.com/download/100/
source = zelda-classic.png
source = zelda-classic-zlaunch.png
source = zelda-classic-zquest.png
@@ -28,11 +24,15 @@ pkgbase = zelda-classic
sha256sums = 44e1c4f0a0bed46ce40cb7659863c797b47d1afcef99c86cc329d10898511c2f
sha256sums = 72bc054a698e36b9a23e3907ac9112aab78b0424c71ba0c9a657cbe78886572c
sha256sums = 7188389790cdc030316231103a76b0e692e4a546fed748d86f15f977907be684
- depends_i686 = libxpm
depends_i686 = libxxf86vm
depends_i686 = libxcursor
depends_i686 = alsa-lib
+ depends_i686 = bash
optdepends_i686 = gtk-engine-murrine: needed for the gtk2-launcher
+ depends_x86_64 = lib32-libxxf86vm
+ depends_x86_64 = lib32-libxcursor
+ depends_x86_64 = lib32-alsa-lib
+ depends_x86_64 = bash
+ optdepends_x86_64 = lib32-gtk-engine-murrine: needed for the gtk2-launcher
pkgname = zelda-classic
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..fc7564ae47a5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!zelda-classic-*
+!zelda-classic.*
diff --git a/PKGBUILD b/PKGBUILD
index ef7962ac6e3b..95bd83a2f627 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
-# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+# Maintainer: Marcell Meszaros < marcell.meszaros AT runbox.eu >
+# Contributor: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
pkgname=zelda-classic
pkgver=2.50.2.29
-pkgrel=1
+pkgrel=2
pkgdesc="A tribute to Nintendo's The Legend of Zelda (NES)"
arch=('i686' 'x86_64')
url="http://zeldaclassic.com"
license=('custom: Freeware')
-depends_i686=('libxpm' 'libxxf86vm' 'libxcursor' 'alsa-lib')
-depends_x86_64=('lib32-libxpm' 'lib32-libxxf86vm' 'lib32-libxcursor' 'lib32-alsa-lib')
+depends_i686=('libxxf86vm' 'libxcursor' 'alsa-lib' 'bash')
+depends_x86_64=('lib32-libxxf86vm' 'lib32-libxcursor' 'lib32-alsa-lib' 'bash')
optdepends_i686=('gtk-engine-murrine: needed for the gtk2-launcher')
optdepends_x86_64=('lib32-gtk-engine-murrine: needed for the gtk2-launcher')
install=$pkgname.install
-source=("https://www.dropbox.com/s/fnipdbanjm8bf2v/zc-2-50-2-linux.tar.gz"
+source=("$pkgname-2-50-2-linux.tar.gz::https://www.zeldaclassic.com/download/100/"
"$pkgname.png"
"$pkgname-zlaunch.png"
"$pkgname-zquest.png"
@@ -28,6 +29,7 @@ sha256sums=('44e105415b1b1d5ca5c625907cf6fc2ce835ddaf9b70a6ace4cd0febe1ae4ed0'
'44e1c4f0a0bed46ce40cb7659863c797b47d1afcef99c86cc329d10898511c2f'
'72bc054a698e36b9a23e3907ac9112aab78b0424c71ba0c9a657cbe78886572c'
'7188389790cdc030316231103a76b0e692e4a546fed748d86f15f977907be684')
+options=('!strip')
package() {
cd "Zelda Classic"