summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYannick Lange2015-01-08 18:29:12 +0100
committerYannick Lange2015-01-08 18:29:12 +0100
commit1363c6b0bffbb518a8ae32d72c82b70963349639 (patch)
tree6e19a6e505104f6fe4c3808febfdebdc56fcc95f
downloadaur-1363c6b0bffbb518a8ae32d72c82b70963349639.tar.gz
Initial commit for 6.11-4
-rw-r--r--.SRCINFO28
-rw-r--r--ChangeLog21
-rw-r--r--PKGBUILD67
-rw-r--r--zelda-roth.desktop11
-rw-r--r--zelda-roth.install18
5 files changed, 145 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..92e61e7e1616
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+# Generated by makepkg 4.2.0
+# Thu Jan 8 17:21:45 UTC 2015
+pkgbase = zelda-roth-fr
+ pkgdesc = Zelda: Return of the Hylian (french version)
+ pkgver = 6.11
+ pkgrel = 4
+ url = http://www.zeldaroth.fr/
+ install = zelda-roth.install
+ changelog = ChangeLog
+ arch = i686
+ arch = x86_64
+ license = Unknown
+ makedepends = imagemagick
+ depends = sdl_gfx
+ depends = sdl_mixer
+ depends = sdl_image
+ depends = xdg-utils
+ depends = hicolor-icon-theme
+ depends = timidity++
+ optdepends = timidity-freepats: soundfont for timidity to be able to have music in game
+ optdepends = fluidr3: another soundfont for timidity to be able to have music in game if you prefer
+ source = http://www.zeldaroth.fr/fichier/ROTH/linux/ZeldaROTH-src-linux.zip
+ source = zelda-roth.desktop
+ md5sums = 3e3f9a3c944491d1cb7683a06437ae38
+ md5sums = e668913f4420520de8775192639997f5
+
+pkgname = zelda-roth-fr
+
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 000000000000..f2edd1b2167e
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,21 @@
+2013-02-28 FoolEcho <foolecho at gmail dot com>
+
+ * 6-11-4 :
+ Added prepare() (pacman 4.1).
+ Code presentation.
+
+ * 6-11-3 :
+ Added ChangeLog.
+ Patched the sources to save and restore the game settings (volumes and ranks) in your HOME (with the saves).
+ Patched the sources to be able to remove old saves from the game menu.
+
+2013-02-25 FoolEcho <foolecho at gmail dot com>
+
+ * 6.11-2 :
+ Added timidity++ as dependency in order to have music in game (musics are .mid ; you need to install and configure a soundfont such as timidity-freepats or fluidr3);
+ Corrections of the PKGBUILD (.install)
+
+2013-02-14 FoolEcho <foolecho at gmail dot com>
+
+ * 6.11-1 :
+ First release (PKGBUILD initially based on zelda-roth-en and so on)
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4fd41ceef2ea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,67 @@
+# Maintainer: FoolEcho <foolecho at gmail dot com>
+pkgname=zelda-roth-fr
+_name=zelda-roth
+pkgver=6.11
+pkgrel=4
+pkgdesc="Zelda: Return of the Hylian (french version)"
+arch=('i686' 'x86_64')
+url="http://www.zeldaroth.fr/"
+license=('Unknown')
+depends=('sdl_gfx' 'sdl_mixer' 'sdl_image' 'xdg-utils' 'hicolor-icon-theme' 'timidity++')
+makedepends=(imagemagick)
+optdepends=('timidity-freepats: soundfont for timidity to be able to have music in game'
+ 'fluidr3: another soundfont for timidity to be able to have music in game if you prefer')
+install=${_name}.install
+changelog=ChangeLog
+source=(
+ "http://www.zeldaroth.fr/fichier/ROTH/linux/ZeldaROTH-src-linux.zip"
+ zelda-roth.desktop)
+md5sums=('3e3f9a3c944491d1cb7683a06437ae38'
+ 'e668913f4420520de8775192639997f5')
+
+prepare () {
+ cd $srcdir/ZeldaROTH-src-linux/src
+
+ # Fix the Game so that it reads save files from $HOME/.zelda-roth
+ sed -i -e s~\"data/save/~string\(getenv\(\"HOME\"\)\)+\"/.$_name/~g Joueur.cpp
+ #save/restore volume settings and ranks
+ sed -i -e s#\"data/save/system.dat\"#\(string\(getenv\(\"HOME\"\)\)+\"/.$_name/system.dat\"\).c_str\(\)#g Keyboard.cpp
+ #remove saves from menu
+ sed -i -e s#\"data/save#string\(getenv\(\"HOME\"\)\)+\"/.$_name#g Keyboard.cpp
+
+ #Make the game treat /usr/share/$pkgname as its data directory
+ for i in *.cpp
+ do
+ sed -i -e s~data/~/usr/share/$pkgname/~g $i
+ done
+
+ # Create the directory $HOME/.zelda-roth if it doesnt exist
+ sed -i -e s~'(NULL));'~'&\n\tif (system(\"stat $HOME/.'$_name' \&> /dev/null")) system (\"mkdir $HOME/.'$_name'\");'~ main.cpp
+}
+
+build () {
+ cd $srcdir/ZeldaROTH-src-linux/src
+ make
+}
+
+package () {
+
+ install -Dm644 $_name.desktop $pkgdir/usr/share/applications/$_name.desktop
+ cd $srcdir/ZeldaROTH-src-linux/src
+
+ install -Dm755 ZeldaROTH $pkgdir/usr/bin/$_name
+
+ cd data
+ for i in {map,music,sound}/*
+ do
+ install -Dm644 $i $pkgdir/usr/share/$pkgname/$i
+ done
+
+ cd images
+ for i in */*
+ do
+ install -Dm644 $i $pkgdir/usr/share/$pkgname/images/$i
+ done
+ mkdir -p $pkgdir/usr/share/icons/hicolor/256x256/apps
+ convert logos/fond.png -resize 256x256\! $pkgdir/usr/share/icons/hicolor/256x256/apps/$_name.png
+}
diff --git a/zelda-roth.desktop b/zelda-roth.desktop
new file mode 100644
index 000000000000..f66b987de12e
--- /dev/null
+++ b/zelda-roth.desktop
@@ -0,0 +1,11 @@
+#!/usr/bin/env xdg-open
+[Desktop Entry]
+Name=ZeldaROTH
+GeneralName=Zelda: Return of the Hylian
+Comment=First Game in a trilogy of fan made Zelda Games
+Comment[fr]=Premier jeu dans une trilogie de jeu Zelda fait par des fans
+Exec=zelda-roth
+Icon=zelda-roth.png
+Terminal=false
+Type=Application
+Categories=Game
diff --git a/zelda-roth.install b/zelda-roth.install
new file mode 100644
index 000000000000..1363f01f17ba
--- /dev/null
+++ b/zelda-roth.install
@@ -0,0 +1,18 @@
+post_install() {
+ echo "update mime database..."
+ update-mime-database /usr/share/mime/ > /dev/null
+ echo "update desktop database..."
+ update-desktop-database -q
+ echo "update icon cache..."
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ echo ""
+ echo "Don't forget to install the package timidity-freepats or fluidr3 and configure /etc/timidity++/timidity.cfg in order to have music in game"
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+} \ No newline at end of file