summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhenil2022-05-10 18:29:39 +0530
committerhenil2022-05-10 18:29:39 +0530
commit0afd5f799687e21e67553d3354df744c3f507ec0 (patch)
tree546f3aa3f068ea6336fdc8c26c6cfb5a030a93d3
parent210742d2c7bf3d97fbe6fe40ba2ebf62965199a6 (diff)
downloadaur-0afd5f799687e21e67553d3354df744c3f507ec0.tar.gz
add cargo-make to makedeps
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD3
2 files changed, 2 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ff3b2ae9d4e1..f6c37e95bdaf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,6 +12,7 @@ pkgbase = zellij-git
makedepends = cargo
makedepends = git
makedepends = binaryen
+ makedepends = cargo-make
provides = zellij
conflicts = zellij
source = git+https://github.com/zellij-org/zellij
diff --git a/PKGBUILD b/PKGBUILD
index c0c22475876f..66c21fb32da7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ url="https://www.github.com/zellij-org/zellij"
license=('MIT')
groups=()
depends=()
-makedepends=('rustup' 'cargo' 'git' 'binaryen')
+makedepends=('rustup' 'cargo' 'git' 'binaryen' 'cargo-make')
checkdepends=()
optdepends=()
provides=('zellij')
@@ -22,7 +22,6 @@ sha256sums=(SKIP)
build() {
cd "$srcdir/$_pkgname"
- cargo install --force cargo-make
cargo make install ./zellij
mkdir -p assets/completions
./zellij setup --generate-completion bash > assets/completions/zellij.bash