summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhenil2022-12-21 22:22:24 +0530
committerhenil2022-12-21 22:22:24 +0530
commit7e3b547ae37bf35523121bfd186e6a3f06ada5be (patch)
tree1aa3d0baea111658ba6e45c3ef09d5af27100cbe
parent0afd5f799687e21e67553d3354df744c3f507ec0 (diff)
downloadaur-7e3b547ae37bf35523121bfd186e6a3f06ada5be.tar.gz
use cargo-xtask instead of cargo-make
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f6c37e95bdaf..1ccd3cbc59d7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = zellij-git
pkgdesc = A terminal workspace with batteries included
- pkgver = r1287.f62ccd2a
+ pkgver = r2207.17205793
pkgrel = 1
url = https://www.github.com/zellij-org/zellij
arch = i686
@@ -12,7 +12,7 @@ pkgbase = zellij-git
makedepends = cargo
makedepends = git
makedepends = binaryen
- makedepends = cargo-make
+ makedepends = mandown
provides = zellij
conflicts = zellij
source = git+https://github.com/zellij-org/zellij
diff --git a/PKGBUILD b/PKGBUILD
index 66c21fb32da7..3e6643bf8af1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Henil <henil2911 + aur at gmail <.> com>
pkgname=zellij-git
_pkgname=zellij
-pkgver=r1287.f62ccd2a
+pkgver=r2207.17205793
_pkgver=0.1
pkgrel=1
epoch=
@@ -11,7 +11,7 @@ url="https://www.github.com/zellij-org/zellij"
license=('MIT')
groups=()
depends=()
-makedepends=('rustup' 'cargo' 'git' 'binaryen' 'cargo-make')
+makedepends=('rustup' 'cargo' 'git' 'binaryen' 'mandown')
checkdepends=()
optdepends=()
provides=('zellij')
@@ -22,7 +22,8 @@ sha256sums=(SKIP)
build() {
cd "$srcdir/$_pkgname"
- cargo make install ./zellij
+ cargo install --locked cargo-xtask
+ cargo xtask install ./zellij
mkdir -p assets/completions
./zellij setup --generate-completion bash > assets/completions/zellij.bash
./zellij setup --generate-completion fish > assets/completions/zellij.fish