summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhenil2021-04-17 14:44:22 +0530
committerhenil2021-04-17 14:44:22 +0530
commit8d79317570a805ad46d891d391abfa2deea4794d (patch)
tree9954966c4c38e4e82090119ed35b813f8b1b140b
parente86bdba3842bc1b3cae6f9eeab21ba7610a7a2d1 (diff)
downloadaur-8d79317570a805ad46d891d391abfa2deea4794d.tar.gz
fix(build): Now using cargo make
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
2 files changed, 7 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f443c6d16cd6..761d46ef900e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = zellij-git
pkgdesc = Terminal Workspace (WIP)
- pkgver = r371.845478f
+ pkgver = r494.7bbd5e2
pkgrel = 1
url = https://www.github.com/zellij-org/zellij
arch = i686
@@ -8,7 +8,7 @@ pkgbase = zellij-git
arch = armv6h
arch = armv7h
license = MIT
- makedepends = rust
+ makedepends = rustup
makedepends = cargo
makedepends = git
makedepends = binaryen
diff --git a/PKGBUILD b/PKGBUILD
index 018c165b0c21..3d61edeb8cda 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Henil <henil2911 + aur at gmail <.> com>
pkgname=zellij-git
_pkgname=zellij
-pkgver=r371.845478f
+pkgver=r494.7bbd5e2
_pkgver=0.1
pkgrel=1
epoch=
@@ -11,7 +11,7 @@ url="https://www.github.com/zellij-org/zellij"
license=('MIT')
groups=()
depends=()
-makedepends=('rust' 'cargo' 'git' 'binaryen')
+makedepends=('rustup' 'cargo' 'git' 'binaryen')
checkdepends=()
optdepends=()
provides=('zellij')
@@ -22,18 +22,14 @@ sha256sums=(SKIP)
build() {
cd "$srcdir/$_pkgname"
- bash ./build-all.sh
- cargo build --locked --release --target-dir target
+ cargo install --force cargo-make
+ cargo make install ./zellij
}
package() {
cd "$srcdir/$_pkgname"
- mkdir -p "${pkgdir}/usr/share/zellij/layouts"
- mkdir -p "${pkgdir}/usr/share/zellij/plugins"
mkdir -p "${pkgdir}/usr/share/doc/zellij"
- install -Dm755 target/release/zellij "${pkgdir}/usr/bin/zellij"
- install -Dm644 assets/layouts/* "${pkgdir}/usr/share/zellij/layouts/"
- install -Dm644 assets/plugins/* "${pkgdir}/usr/share/zellij/plugins/"
+ install -Dm755 ./zellij "${pkgdir}/usr/bin/zellij"
install -Dm644 GOVERNANCE.md "${pkgdir}/usr/share/doc/zellij/GOVERNANCE.md"
install -Dm644 README.md "${pkgdir}/usr/share/doc/zellij/README.md"
install -Dm644 assets/completions/zellij.bash "${pkgdir}/usr/share/bash-completion/completions/zellij.bash"