summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMilan Oberkirch2015-03-07 21:33:56 +1300
committerMilan Oberkirch2015-03-07 21:33:56 +1300
commit81249e85e1340a24747fecd0fba72cf21298066e (patch)
tree20d0678baea455d0dabee4bf894ac0a3959ea7c7
downloadaur-81249e85e1340a24747fecd0fba72cf21298066e.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD41
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5ac8abd7d3d5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = zenbu-login
+ pkgdesc = Automates login to zenbu.net.nz wifi networks.
+ pkgver = 0.01
+ pkgrel = 0
+ url = http://oberkirch.org
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = curl
+ depends = bash
+ depends = grep
+ backup = etc/zenbu-login
+
+pkgname = zenbu-login
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6cf5bf838aee
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+*.tar
+*.tar.*
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bce2c0ef194d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Milan Oberkirch <aur@oberkirch.org>
+pkgname=zenbu-login
+pkgver=0.01
+pkgrel=0
+pkgdesc="Automates login to zenbu.net.nz wifi networks."
+arch=('any')
+url="http://oberkirch.org"
+license=('GPL3')
+depends=('curl' 'bash' 'grep')
+backup=('etc/zenbu-login')
+makedepends=('git')
+md5sums=()
+
+_gitroot="git@github.com:zvyn/zenbu-login.git"
+_gitname=zenbu-login
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [[ -d "$_gitname" ]]; then
+ cd "$_gitname" && git pull origin
+ msg "The local files are updated."
+ else
+ git clone "$_gitroot" "$_gitname"
+ fi
+
+ msg "GIT checkout done or server timeout"
+}
+
+package() {
+ mkdir -p "${pkgdir}/etc" "${pkgdir}/usr/bin"
+ cp "$srcdir/$_gitname/zenbu-login.bash" "${pkgdir}/usr/bin/zenbu-login"
+ chmod +x "${pkgdir}/usr/bin/zenbu-login"
+ cat <<EndOfFile > "${pkgdir}/etc/zenbu-login"
+username=
+password=
+EndOfFile
+}
+
+# vim:set ts=2 sw=2 et: