summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormurlakatamenka2020-03-16 19:32:58 +0300
committermurlakatamenka2020-03-16 19:32:58 +0300
commitcd90012d07bf1ddd909cce03ea3ca42b322f71e6 (patch)
treea0a313188a3904de8e2f791fdfe33e9566b64616
downloadaur-cd90012d07bf1ddd909cce03ea3ca42b322f71e6.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD17
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1ad17281c364
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = zenith-bin
+ pkgdesc = Terminal system usage information written in Rust
+ pkgver = 0.7.4
+ pkgrel = 1
+ url = https://github.com/bvaisvil/zenith
+ arch = x86_64
+ license = MIT
+ provides = zenith
+ conflicts = zenith
+ source = zenith-bin-0.7.4.tar.gz::https://github.com/bvaisvil/zenith/releases/download/0.7.4/zenith.linux.tgz
+ md5sums = bf9326d39279a1c8370e70abee1faacf
+
+pkgname = zenith-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c92f42431530
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Sergey A. <murlakatamenka@disroot.org>
+
+pkgname=zenith-bin
+pkgver=0.7.4
+pkgrel=1
+pkgdesc="Terminal system usage information written in Rust"
+arch=('x86_64')
+url="https://github.com/bvaisvil/zenith"
+license=('MIT')
+provides=('zenith')
+conflicts=('zenith')
+source=("$pkgname-$pkgver.tar.gz::$url/releases/download/$pkgver/zenith.linux.tgz")
+md5sums=('bf9326d39279a1c8370e70abee1faacf')
+
+package() {
+ install -Dm 755 "zenith" "$pkgdir/usr/bin/zenith"
+}