summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSumedh Wale2020-10-09 00:11:34 +0530
committerSumedh Wale2020-10-09 00:11:34 +0530
commit9912c4583edac87579406ebb3e375a67eaf3d228 (patch)
tree9452ae7ed5b54275486864280be4acb16d66abfc
parent88018ae0ae0fd89c7534d311f8e3152674b7722b (diff)
downloadaur-9912c4583edac87579406ebb3e375a67eaf3d228.tar.gz
switch to make for the build
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 882dbb0efc83..a3b5cac8b01d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = zenith-git
pkgdesc = In terminal graphical metrics for your *nix system written in Rust
- pkgver = r174.cbe523d
- pkgrel = 3
+ pkgver = r364.3400294
+ pkgrel = 1
url = https://github.com/bvaisvil/zenith
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 95bac9a3f9bd..f048b2a494dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=zenith-git
-pkgver=r174.cbe523d
-pkgrel=3
+pkgver=r364.3400294
+pkgrel=1
pkgdesc='In terminal graphical metrics for your *nix system written in Rust'
arch=('x86_64')
url='https://github.com/bvaisvil/zenith'
@@ -20,10 +20,11 @@ pkgver() {
build() {
cd "$srcdir/${pkgname%-git}"
- cargo build --release
+ make
}
package() {
cd "$srcdir/${pkgname%-git}"
- install -Dm755 "target/release/${pkgname%-git}" "${pkgdir}/usr/bin/${pkgname%-git}"
-} \ No newline at end of file
+ make install PREFIX=/usr DESTDIR="${pkgdir}"
+ install -D -m 644 README.md "${pkgdir}/usr/share/doc/zenith/README.md"
+}