summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy_Vetrov2019-02-16 22:17:37 +0300
committerAndy_Vetrov2019-02-16 22:17:37 +0300
commit4555e295919e0e815eea1473fae1a1de9e114940 (patch)
treee3923611a08738e5d3004140b15827613f43007b
downloadaur-4555e295919e0e815eea1473fae1a1de9e114940.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD47
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..988083229e18
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = zenity-git
+ pkgdesc = Display graphical dialog boxes from shell scripts. Webkit-free version.
+ pkgver = 3.30.0.r10.g3fe41e2
+ pkgrel = 1
+ url = https://gitlab.gnome.org/GNOME/zenity
+ arch = x86_64
+ license = LGPL
+ makedepends = gettext
+ makedepends = gnome-common
+ makedepends = git
+ makedepends = itstool
+ makedepends = yelp-tools
+ depends = libnotify
+ provides = zenity=3.30.0.r10.g3fe41e2
+ conflicts = zenity
+ replaces = zenity
+ source = git+https://gitlab.gnome.org/GNOME/zenity.git
+ sha256sums = SKIP
+
+pkgname = zenity-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cbb6d06fbca6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Based on the file created for Arch Linux by:
+# Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Jan de Groot <jgc@archlinux.org>
+#
+# Removed webkit2gtk dependency:
+# https://github.com/QubesOS/qubes-issues/issues/3279
+# https://bugs.archlinux.org/task/50548
+
+pkgname=zenity-git
+pkgver=3.30.0.r10.g3fe41e2
+pkgrel=1
+pkgdesc="Display graphical dialog boxes from shell scripts. Webkit-free version."
+url="https://gitlab.gnome.org/GNOME/zenity"
+arch=(x86_64)
+license=(LGPL)
+provides=("zenity=$pkgver")
+conflicts=('zenity')
+replaces=('zenity')
+depends=('libnotify')
+makedepends=(gettext gnome-common git itstool yelp-tools)
+source=("git+https://gitlab.gnome.org/GNOME/zenity.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname%-*}
+ git describe --long --tags | sed 's/^ZENITY_//;s/_/./g;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd ${pkgname%-*}
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+ cd ${pkgname%-*}
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --disable-webkitgtk \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ cd ${pkgname%-*}
+ make DESTDIR="${pkgdir}" install
+}