summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-06-10 23:54:14 -0600
committerBrian Bidulock2015-06-10 23:54:14 -0600
commit994dcf2a7601ddc592ac0660ab0241baa783b9cb (patch)
tree3f1f71d5f45c30dce909d0e248a18ee43484da48
downloadaur-994dcf2a7601ddc592ac0660ab0241baa783b9cb.tar.gz
initial version
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD32
-rw-r--r--notify_notification_new.patch15
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..65be8cdcac84
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = zenity-gtk2
+ pkgdesc = Display graphical dialog boxes from shell scripts. GTK2 version.
+ pkgver = 2.32.1
+ pkgrel = 4
+ url = http://www.gnome.org
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = intltool
+ makedepends = gtk-doc
+ makedepends = gnome-doc-utils
+ depends = gtk2
+ depends = libnotify
+ provides = zenity
+ conflicts = zenity
+ source = http://ftp.gnome.org/pub/gnome/sources/zenity/2.32/zenity-2.32.1.tar.gz
+ source = notify_notification_new.patch
+ sha256sums = 75d858e5f0bdcb4de7ec6b753370b46da69af69462208cebca2c144c824808d1
+ sha256sums = efea2489756ac9c126dcd81d071c1efa331966942f8ece7a2cb55fd9168115e4
+
+pkgname = zenity-gtk2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..751e63aafae6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Contributor: OK100 <ok100.ok100.ok100@gmail.com>
+
+pkgname=zenity-gtk2
+pkgver=2.32.1
+pkgrel=4
+pkgdesc="Display graphical dialog boxes from shell scripts. GTK2 version."
+arch=(i686 x86_64)
+license=('LGPL')
+depends=('gtk2' 'libnotify')
+makedepends=('intltool' 'gtk-doc' 'gnome-doc-utils')
+conflicts=('zenity')
+provides=('zenity')
+url="http://www.gnome.org"
+source=(http://ftp.gnome.org/pub/gnome/sources/zenity/${pkgver%.*}/zenity-${pkgver}.tar.gz
+ notify_notification_new.patch)
+sha256sums=('75d858e5f0bdcb4de7ec6b753370b46da69af69462208cebca2c144c824808d1'
+ 'efea2489756ac9c126dcd81d071c1efa331966942f8ece7a2cb55fd9168115e4')
+
+build() {
+ cd "${srcdir}/zenity-${pkgver}/src"
+ patch < "${srcdir}/notify_notification_new.patch"
+ cd "${srcdir}/zenity-${pkgver}"
+ ./configure --prefix=/usr --sysconfdir=/etc \
+ --localstatedir=/var --disable-scrollkeeper
+ make
+}
+
+package() {
+ cd "${srcdir}/zenity-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/notify_notification_new.patch b/notify_notification_new.patch
new file mode 100644
index 000000000000..4e5e50051453
--- /dev/null
+++ b/notify_notification_new.patch
@@ -0,0 +1,15 @@
+--- /tmp/notification.c
++++ /home/ok/build/pkgbuilds/zenity-gtk2/src/zenity-2.32.1/src/notification.c
+@@ -184,10 +184,10 @@
+ icon = freeme = g_filename_to_uri (icon_file, NULL, NULL);
+ }
+
+- notif = notify_notification_new_with_status_icon (
++ notif = notify_notification_new(
+ message[0] /* title */,
+ message[1] /* summary */,
+- icon, status_icon);
++ icon);
+
+ g_strfreev (message);
+ g_free (freeme);