summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmil Velikov2022-02-13 17:13:48 +0000
committerEmil Velikov2022-02-13 17:13:48 +0000
commit035e5b5bd0d2a1026207f80a04db8017676ecbab (patch)
treeb6940f7c49329f78a1693380107e9954f82457ae
parent30db49e32b02626c371fb6b872ceeefb5c32b698 (diff)
downloadaur-035e5b5bd0d2a1026207f80a04db8017676ecbab.tar.gz
zenity-light: update to 3.41.0-1
Signed-off-by: Emil Velikov <emil.l.velikov@gmail.com>
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD26
2 files changed, 17 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f68c11802fa4..9f525d4decd0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,18 @@
pkgbase = zenity-light
pkgdesc = Display graphical dialog boxes from shell scripts. Light version without WekKit2.
- pkgver = 3.32.0+55+gd7bedff
+ pkgver = 3.41.0
pkgrel = 1
url = https://gitlab.gnome.org/GNOME/zenity
arch = x86_64
license = LGPL
makedepends = yelp-tools
- makedepends = autoconf-archive
+ makedepends = meson
makedepends = git
- makedepends = perl
depends = gtk3
depends = libnotify
provides = zenity
conflicts = zenity
- source = git+https://gitlab.gnome.org/GNOME/zenity.git#commit=d7bedff683df43df0604f989659df48f096f8c0e
+ source = git+https://gitlab.gnome.org/GNOME/zenity.git#commit=d8857f446b602d5fb4a41fef3d8a63507a12b72c
sha256sums = SKIP
pkgname = zenity-light
-
diff --git a/PKGBUILD b/PKGBUILD
index 19df85470ce2..e7a479bc6c69 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,38 +3,40 @@
# Contributor: Jan de Groot <jgc@archlinux.org>
pkgname=zenity-light
-pkgver=3.32.0+55+gd7bedff
+pkgver=3.41.0
pkgrel=1
pkgdesc="Display graphical dialog boxes from shell scripts. Light version without WekKit2."
url="https://gitlab.gnome.org/GNOME/zenity"
arch=(x86_64)
license=(LGPL)
depends=(gtk3 libnotify)
-makedepends=(yelp-tools autoconf-archive git perl)
+makedepends=(yelp-tools meson git)
conflicts=("${pkgname%-light}")
provides=("${pkgname%-light}")
-_commit=d7bedff683df43df0604f989659df48f096f8c0e # master
+_commit=d8857f446b602d5fb4a41fef3d8a63507a12b72c # tags/3.41.0^0
source=("git+https://gitlab.gnome.org/GNOME/zenity.git#commit=$_commit")
sha256sums=('SKIP')
pkgver() {
- cd ${pkgbase%-light}
+ cd zenity
git describe --tags | sed 's/^ZENITY_//;s/_/./g;s/-/+/g'
}
prepare() {
- cd ${pkgbase%-light}
- NOCONFIGURE=1 ./autogen.sh
+ cd zenity
}
build() {
- cd ${pkgbase%-light}
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
- --disable-webkitgtk
- make
+ arch-meson zenity build \
+ -D libnotify=true \
+ -D webkitgtk=false
+ meson compile -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
}
package() {
- cd ${pkgbase%-light}
- make DESTDIR="$pkgdir" install
+ meson install -C build --destdir "$pkgdir"
}