summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmil Velikov2020-12-01 06:39:34 +0000
committerEmil Velikov2020-12-01 06:39:34 +0000
commit30db49e32b02626c371fb6b872ceeefb5c32b698 (patch)
tree69758a05aced58a83fcfe6da81106320214ed08a
downloadaur-30db49e32b02626c371fb6b872ceeefb5c32b698.tar.gz
zenity-light: zenity w/o webkit2 import 3.32.0+55+gd7bedff
Signed-off-by: Emil Velikov <emil.l.velikov@gmail.com>
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD40
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f68c11802fa4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = zenity-light
+ pkgdesc = Display graphical dialog boxes from shell scripts. Light version without WekKit2.
+ pkgver = 3.32.0+55+gd7bedff
+ pkgrel = 1
+ url = https://gitlab.gnome.org/GNOME/zenity
+ arch = x86_64
+ license = LGPL
+ makedepends = yelp-tools
+ makedepends = autoconf-archive
+ makedepends = git
+ makedepends = perl
+ depends = gtk3
+ depends = libnotify
+ provides = zenity
+ conflicts = zenity
+ source = git+https://gitlab.gnome.org/GNOME/zenity.git#commit=d7bedff683df43df0604f989659df48f096f8c0e
+ sha256sums = SKIP
+
+pkgname = zenity-light
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..19df85470ce2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Emil Velikov <emil.l.velikov@gmail.com>
+# Contributor: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+
+pkgname=zenity-light
+pkgver=3.32.0+55+gd7bedff
+pkgrel=1
+pkgdesc="Display graphical dialog boxes from shell scripts. Light version without WekKit2."
+url="https://gitlab.gnome.org/GNOME/zenity"
+arch=(x86_64)
+license=(LGPL)
+depends=(gtk3 libnotify)
+makedepends=(yelp-tools autoconf-archive git perl)
+conflicts=("${pkgname%-light}")
+provides=("${pkgname%-light}")
+_commit=d7bedff683df43df0604f989659df48f096f8c0e # master
+source=("git+https://gitlab.gnome.org/GNOME/zenity.git#commit=$_commit")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${pkgbase%-light}
+ git describe --tags | sed 's/^ZENITY_//;s/_/./g;s/-/+/g'
+}
+
+prepare() {
+ cd ${pkgbase%-light}
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+ cd ${pkgbase%-light}
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
+ --disable-webkitgtk
+ make
+}
+
+package() {
+ cd ${pkgbase%-light}
+ make DESTDIR="$pkgdir" install
+}