summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenedikt Rips2021-04-12 14:13:17 +0200
committerBenedikt Rips2021-04-12 15:07:55 +0200
commit508033beb35ad6ba54af5d670a4199ee922eabbf (patch)
tree08494d3fcdac227aa3f99215c1a9fc9f1bb13f23
parent573bcf2c4fb7cbe36bf6da9d2d37a81dea2842b7 (diff)
downloadaur-508033beb35ad6ba54af5d670a4199ee922eabbf.tar.gz
Remove irrelevant options
The package is not split, hence there is no `$pkgbase`. The `$provides` is not needed since there is no related package.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD14
2 files changed, 8 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ee18ff6a6024..66ca22fe9623 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = zenkit
pkgdesc = A platform for collaboration and project management
pkgver = 20201217
- pkgrel = 3
+ pkgrel = 4
url = https://zenkit.com
arch = x86_64
license = Commercial
depends = alsa-lib
depends = gtk3
depends = nss
- optdepends = xdg-utils: for opening links (e.g. for logging in via 3rd party accounts)
- provides = zenki
+ optdepends = xdg-utils: for opening links, e.g. for logging in via 3rd party accounts
options = !strip
source = https://static.zenkit.com/downloads/desktop-apps/base/zenkit-base-linux.tar.gz
source = https://zenkit.com/favicon.ico
diff --git a/PKGBUILD b/PKGBUILD
index 49334243fda4..2b73a6e52ded 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,15 @@
# Contributor: Lukas Becker <lukasbecker2 [at] [common mail ending from the company behind the most used search engine]>
# Contributor: Benedikt Rips <benedikt.rips@gmail.com>
-pkgbase=zenkit
pkgname=zenkit
pkgver=20201217
-pkgrel=3
+pkgrel=4
pkgdesc='A platform for collaboration and project management'
arch=('x86_64')
url='https://zenkit.com'
license=('Commercial')
depends=('alsa-lib' 'gtk3' 'nss')
-optdepends=('xdg-utils: for opening links (e.g. for logging in via 3rd party accounts)')
-provides=('zenki')
+optdepends=('xdg-utils: for opening links, e.g. for logging in via 3rd party accounts')
options=('!strip')
source=('https://static.zenkit.com/downloads/desktop-apps/base/zenkit-base-linux.tar.gz'
'https://zenkit.com/favicon.ico'
@@ -24,9 +22,9 @@ sha512sums=('b34633e89c6778d5c2ca3f9928215ce356ff9d44303cdad6fe71731e57873500aab
package() {
install -dm755 "${pkgdir}/opt"
- cp -a zenkit-base-linux "${pkgdir}/opt/${pkgbase}"
- install -Dm644 favicon.ico "${pkgdir}/opt/${pkgbase}/${pkgbase}.ico"
- install -Dm644 "${pkgbase}.desktop" "${pkgdir}/usr/share/applications/${pkgbase}.desktop"
+ cp -a zenkit-base-linux "${pkgdir}/opt/${pkgname}"
+ install -Dm644 favicon.ico "${pkgdir}/opt/${pkgname}/${pkgname}.ico"
+ install -Dm644 "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
install -dm755 "${pkgdir}/usr/bin"
- ln -s "/opt/${pkgbase}/${pkgbase}" "${pkgdir}/usr/bin/${pkgbase}"
+ ln -s "/opt/${pkgname}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
}