summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormatan h2022-09-29 13:39:56 +0300
committermatan h2022-09-29 13:39:56 +0300
commit63034ec66ecf92f00904d89bc517c029f2dde371 (patch)
tree2fb2d33682cf5b77750976bde6b5f35dc445c8e3
parent76d64036056d8f5b6d8652c768f31b514df04592 (diff)
downloadaur-63034ec66ecf92f00904d89bc517c029f2dde371.tar.gz
fix pkgver
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 512a2cca3ae7..ba56217b6d49 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,10 +8,10 @@ pkgbase = zenmap-python3-git
makedepends = unzip
depends = nmap
depends = gtk3
- depends = gobject
+ depends = python-gobject
optdepends = gksu: starting zenmap as root
provides = zenmap
- source = zenmap-python3-git-7.92SVN.zip::https://github.com/kulikjak/nmap/archive/refs/heads/master-python3.zip
- md5sums = 931711d6aa99b266d1cde4df7ed63cd8
+ source = https://github.com/kulikjak/nmap/archive/refs/heads/master-python3.zip
+ md5sums = SKIP
pkgname = zenmap-python3-git
diff --git a/PKGBUILD b/PKGBUILD
index dab3e25a21d1..ae8311d31c78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Matan h <matan.honig2@gmail.com>
pkgname="zenmap-python3-git"
-pkgver="7.92SVN"
+pkgver=7.92SVN
pkgrel=1
pkgdesc="Graphical Nmap frontend and results viewer - rerwite in python 3"
arch=("any")
@@ -16,7 +16,11 @@ optdepends=("gksu: starting zenmap as root")
provides=("zenmap")
source=("https://github.com/kulikjak/nmap/archive/refs/heads/master-python3.zip")
-md5sums=("931711d6aa99b266d1cde4df7ed63cd8")
+md5sums=("SKIP")
+
+pkgver() {
+ cat "$srcdir/nmap-master-python3/zenmap/share/zenmap/config/zenmap_version"
+}
package() {
cd "$srcdir/nmap-master-python3/zenmap"