summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorМаксим Новиков2023-05-24 13:34:02 +0300
committerМаксим Новиков2023-05-24 13:34:02 +0300
commitdcc965d46bea144ba25a2b4d76fa18b14848d908 (patch)
tree6b43ce2b3ffb08c4cce55b14323082fdc37c0463
parent551367d322a3309c525c6a2e20ae4176326dc45e (diff)
downloadaur-dcc965d46bea144ba25a2b4d76fa18b14848d908.tar.gz
update to v0.17.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 40e3f9af028e..0b715114a8fb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = zephir
pkgdesc = Zephir is a compiled high level language aimed to the creation of C-extensions for PHP http://zephir-lang.com/
- pkgver = 0.11.12
+ pkgver = 0.17.0
pkgrel = 1
- url = https://github.com/phalcon/zephir
+ url = https://github.com/zephir-lang/zephir
arch = x86_64
arch = i686
license = MIT
- makedepends = php
depends = php-zephir-parser
- source = https://github.com/phalcon/zephir/releases/download/0.11.12/zephir.phar
- sha256sums = 9224a5f3429d2565948dc2d1a6c1f467268c103b9205d01f277608c64bf514e2
+ depends = php
+ source = https://github.com/zephir-lang/zephir/releases/download/0.17.0/zephir.phar
+ sha256sums = d20d9e340b5b7c395b30a96101496e8139fb14ba478a5322f5e7a018a36ed373
pkgname = zephir
-
diff --git a/PKGBUILD b/PKGBUILD
index cafe72cd127d..0f14d20c30ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,22 @@
-# Maintainer: wolftankk <wolftankk@gmail.com>
+# Maintainer: Maxim Novikov <the.mlex@gmail.com>
pkgname=zephir
-pkgver=0.11.12
+pkgver=0.17.0
pkgrel=1
pkgdesc="Zephir is a compiled high level language aimed to the creation of C-extensions for PHP http://zephir-lang.com/"
-url="https://github.com/phalcon/zephir"
+url="https://github.com/zephir-lang/zephir"
arch=('x86_64' 'i686')
license=('MIT')
-depends=('php-zephir-parser')
-makedepends=('php')
+depends=('php-zephir-parser' 'php')
if [[ $CARCH = "i686" ]]; then
makedepends+=('lib32-pcre');
fi
source=(
- "https://github.com/phalcon/zephir/releases/download/${pkgver}/zephir.phar"
+ "https://github.com/zephir-lang/zephir/releases/download/${pkgver}/zephir.phar"
)
-sha256sums=('9224a5f3429d2565948dc2d1a6c1f467268c103b9205d01f277608c64bf514e2')
+sha256sums=('d20d9e340b5b7c395b30a96101496e8139fb14ba478a5322f5e7a018a36ed373')
package() {
ZEPHIRDIR=/opt/$pkgname