summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorogden2022-04-12 13:57:39 -0700
committerogden2022-04-12 13:57:39 -0700
commitd6887bce63d2b934614f65496fe02b6ae26e3453 (patch)
tree272e2c40ea3f36a3b22887373665537e6b9c07bd
parentdeaf05eedef4408fd1d965f80191e7cee75532ab (diff)
downloadaur-d6887bce63d2b934614f65496fe02b6ae26e3453.tar.gz
0.14.1
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e50cf56552e3..4edc38a1230f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = zephyr-sdk
pkgdesc = SDK for Zephyr real-time operating system
- pkgver = 0.14.0
+ pkgver = 0.14.1
pkgrel = 1
url = https://www.zephyrproject.org/
install = zephyr-sdk.install
@@ -48,7 +48,7 @@ pkgbase = zephyr-sdk
options = !strip
source = https://github.com/zephyrproject-rtos/sdk-ng/releases/download/v0.14.0/zephyr-sdk-0.14.0_linux-x86_64.tar.gz
source = zephyrrc
- sha256sums = eb486e1944c715c984410481425c75f8c019a3a9aaec885a23ce1a2059498ba0
+ sha256sums = b7b70e5e70968ac6ae3184c90c3f3f8a6836acadd1432bf7b3702be7a1d317d8
sha256sums = 7a1257272c64bdec281283d391e3149cece065935c9e8394d6bece32d0f6fc05
pkgname = zephyr-sdk
diff --git a/PKGBUILD b/PKGBUILD
index ab7c5c6d6141..158b3fd4c0d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alexei Colin <ac@alexeicolin.com>
pkgname=zephyr-sdk
-pkgver=0.14.0
+pkgver=0.14.1
pkgrel=1
pkgdesc="SDK for Zephyr real-time operating system"
arch=('x86_64')
@@ -53,13 +53,16 @@ package ()
# -R disables relocation, -S saves the relocation script so that it can be run manually.
sed -i 's#\(\./zephyr-sdk-\${HOSTTYPE}-hosttools-standalone-[0-9.]\+sh\)#\1 -R -S#' $pkgdir/$_installdir/$_setupsh
+ # Disables sanboxing on systems where libseccomp is available
+ sed -i 's/xargs -n100 file/xargs -n100 file -S/' $pkgdir/$_installdir/zephyr-sdk-x86_64-hosttools-standalone-*.sh
+
install -Dm644 zephyrrc $pkgdir/usr/share/zephyr-sdk/zephyrrc
cd $pkgdir/$_installdir
######### NOTE: we are in $_installdir after this point
- ./$_setupsh -t
+ ./$_setupsh -h -t all
# Manually install the CMake module, because upstream paths are no good:
# file installed into $HOME and path is the package build path. Upstream
@@ -80,6 +83,8 @@ package ()
./relocate_sdk.sh
rm zephyr-sdk-*-hosttools-standalone-*.sh
+ rm relocate_sdk.{py,sh}
+ rm setup.sh
}
# Manual test procedure: get Zephyr Kernel, build an example, and run in Qemu:
@@ -110,5 +115,5 @@ package ()
# More info: https://docs.zephyrproject.org/latest/getting_started/index.html
-sha256sums=('eb486e1944c715c984410481425c75f8c019a3a9aaec885a23ce1a2059498ba0'
+sha256sums=('b7b70e5e70968ac6ae3184c90c3f3f8a6836acadd1432bf7b3702be7a1d317d8'
'7a1257272c64bdec281283d391e3149cece065935c9e8394d6bece32d0f6fc05')