summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaichi Shinozaki2015-06-09 18:34:14 +0900
committerDaichi Shinozaki2015-06-09 18:34:14 +0900
commit49419328809c570f50b293280f2966b600d89259 (patch)
treedd33f00ce79083db5cc97afe8d74de2914c42a69
downloadaur-49419328809c570f50b293280f2966b600d89259.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
-rw-r--r--stress_value_test.cpp.patch25
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ae7eed4bee6c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = zero-cache
+ pkgdesc = A Open Source cross-platform distributed memory caching system based on ZMQ messaging library
+ pkgver = 2.2
+ pkgrel = 2
+ url = http://zero-cache.blogspot.com/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = git
+ depends = zeromq
+ source = git+https://github.com/ellysh/zero-cache.git#tag=2.2
+ source = stress_value_test.cpp.patch
+ md5sums = SKIP
+ md5sums = 9da6d84906605aa909f00af4c7a2529b
+
+pkgname = zero-cache
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..159e04bbb621
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Daichi Shinozaki <dsdseg@gmail.com>
+pkgname=zero-cache
+pkgver=2.2
+pkgrel=2
+pkgdesc="A Open Source cross-platform distributed memory caching system based on ZMQ messaging library"
+arch=(i686 x86_64)
+url="http://zero-cache.blogspot.com/"
+source=("git+https://github.com/ellysh/zero-cache.git#tag=$pkgver"
+ 'stress_value_test.cpp.patch')
+license=('GPL')
+depends=('zeromq')
+makedepends=('cmake' 'git')
+md5sums=('SKIP'
+ '9da6d84906605aa909f00af4c7a2529b')
+
+build() {
+ cd "$srcdir/$pkgname"
+ patch --verbose -p1 < "$srcdir"/stress_value_test.cpp.patch
+ cmake -D CMAKE_MODULE_PATH=$PWD -D CMAKE_INSTALL_PREFIX=/usr -D CMAKE_BUILD_TYPE=Release CMakeLists.txt
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/stress_value_test.cpp.patch b/stress_value_test.cpp.patch
new file mode 100644
index 000000000000..8b77e6b851a2
--- /dev/null
+++ b/stress_value_test.cpp.patch
@@ -0,0 +1,25 @@
+diff --git a/test/stress_array_test.cpp b/test/stress_array_test.cpp
+index 3592b61..dcdd043 100644
+--- a/test/stress_array_test.cpp
++++ b/test/stress_array_test.cpp
+@@ -6,6 +6,7 @@
+
+ #include "untyped_client.h"
+ #include "thread.h"
++#include <unistd.h>
+
+ using namespace std;
+ using namespace zero_cache;
+diff --git a/test/stress_value_test.cpp b/test/stress_value_test.cpp
+index c93926a..929d4df 100644
+--- a/test/stress_value_test.cpp
++++ b/test/stress_value_test.cpp
+@@ -5,7 +5,7 @@
+
+ #include "typed_client.h"
+ #include "thread.h"
+-
++#include <unistd.h>
+ using namespace std;
+ using namespace zero_cache;
+