summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoe George2015-09-15 15:06:20 -0400
committerJoe George2015-09-15 15:06:20 -0400
commit5c97e1aac6ec3283d393a94d8b5f67048c40637e (patch)
tree697486c107722c49382f9eff34bb920a8e342ebf
parent67a1e2755d244cc0119ca58db691201670902cfd (diff)
downloadaur-5c97e1aac6ec3283d393a94d8b5f67048c40637e.tar.gz
Update to 3.6.1 and cleanup old files
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD18
-rw-r--r--cpp_Make.rules.patch27
-rw-r--r--java8-compatibility.patch29
-rw-r--r--java_build.properties.patch23
-rw-r--r--php_Make.rules.php.patch35
-rw-r--r--python2_Make.rules.patch35
-rw-r--r--python3_Make.rules.patch35
9 files changed, 18 insertions, 198 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b7e46c687f22..df59d5d26012 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = zeroc-ice
pkgdesc = An object-oriented middleware that provides object-oriented Remote Procedure Call functionality
- pkgver = 3.6.0
+ pkgver = 3.6.1
pkgrel = 1
url = https://zeroc.com
install = ice.install
@@ -14,10 +14,10 @@ pkgbase = zeroc-ice
makedepends = java-environment
makedepends = java-berkeleydb>=5.3
depends = mcpp>=2.7.2
- source = ice-3.6.0.tar.gz::https://github.com/zeroc-ice/ice/archive/v3.6.0.tar.gz
- source = ice-packaging-3.6.0.tar.gz::https://github.com/zeroc-ice/ice-packaging/archive/v3.6.0.tar.gz
- sha256sums = 77933580cdc7fade0ebfce517935819e9eef5fc6b9e3f4143b07404daf54e25e
- sha256sums = f995dbd8ec64d301c3abcf8697b243e1b8b051c799d17acc82a4a2c681834a34
+ source = ice-3.6.1.tar.gz::https://github.com/zeroc-ice/ice/archive/v3.6.1.tar.gz
+ source = ice-packaging-3.6.1.tar.gz::https://github.com/zeroc-ice/ice-packaging/archive/v3.6.1.tar.gz
+ sha256sums = 454d81cb72986c1f04e297a81bca7563e3449a216ad63de8630122d34545ae78
+ sha256sums = 91e340c404047ebf05a787ab992ed175b086ce306070da1768b5817e38385748
pkgname = zeroc-ice
backup = etc/glacier2router.conf
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..01b36d2c5a27
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src
+pkg
+/*.tar.xz
+/*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 6b72c08f35c2..89c8d6dad1a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ pkgname=(
)
pkgbase=("zeroc-ice")
-pkgver=3.6.0
+pkgver=3.6.1
pkgrel=1
pkgdesc="An object-oriented middleware that provides object-oriented Remote Procedure Call functionality"
arch=("i686" "x86_64")
@@ -31,8 +31,8 @@ source=(
"ice-packaging-${pkgver}.tar.gz::https://github.com/zeroc-ice/ice-packaging/archive/v${pkgver}.tar.gz"
)
-sha256sums=('77933580cdc7fade0ebfce517935819e9eef5fc6b9e3f4143b07404daf54e25e'
- 'f995dbd8ec64d301c3abcf8697b243e1b8b051c799d17acc82a4a2c681834a34')
+sha256sums=('454d81cb72986c1f04e297a81bca7563e3449a216ad63de8630122d34545ae78'
+ '91e340c404047ebf05a787ab992ed175b086ce306070da1768b5817e38385748')
install=ice.install
_make_args="OPTIMIZE=yes embedded_runpath=prefix='' prefix=/usr"
@@ -79,15 +79,15 @@ package_zeroc-ice() {
fi
msg2 "Installing systemd services..."
- install -Dm644 ${srcdir}/ice-packaging-${pkgver}/rpm/glacier2router.conf ${pkgdir}/etc/glacier2router.conf
- install -Dm644 ${srcdir}/ice-packaging-${pkgver}/rpm/icegridnode.conf ${pkgdir}/etc/icegridnode.conf
- install -Dm644 ${srcdir}/ice-packaging-${pkgver}/rpm/icegridregistry.conf ${pkgdir}/etc/icegridregistry.conf
+ install -Dm644 ${srcdir}/ice-packaging-${pkgver}/ice/rpm/glacier2router.conf ${pkgdir}/etc/glacier2router.conf
+ install -Dm644 ${srcdir}/ice-packaging-${pkgver}/ice/rpm/icegridnode.conf ${pkgdir}/etc/icegridnode.conf
+ install -Dm644 ${srcdir}/ice-packaging-${pkgver}/ice/rpm/icegridregistry.conf ${pkgdir}/etc/icegridregistry.conf
- install -Dm644 ${srcdir}/ice-packaging-${pkgver}/rpm/glacier2router.service \
+ install -Dm644 ${srcdir}/ice-packaging-${pkgver}/ice/common/systemd/glacier2router.service \
${pkgdir}/usr/lib/systemd/system/glacier2router.service
- install -Dm644 ${srcdir}/ice-packaging-${pkgver}/rpm/icegridnode.service \
+ install -Dm644 ${srcdir}/ice-packaging-${pkgver}/ice/common/systemd/icegridnode.service \
${pkgdir}/usr/lib/systemd/system/icegridnode.service
- install -Dm644 ${srcdir}/ice-packaging-${pkgver}/rpm/icegridregistry.service \
+ install -Dm644 ${srcdir}/ice-packaging-${pkgver}/ice/common/systemd/icegridregistry.service \
${pkgdir}/usr/lib/systemd/system/icegridregistry.service
rm -f ${pkgdir}/usr/share/Ice-${pkgver}/LICENSE
diff --git a/cpp_Make.rules.patch b/cpp_Make.rules.patch
deleted file mode 100644
index aadbd6fe87e0..000000000000
--- a/cpp_Make.rules.patch
+++ /dev/null
@@ -1,27 +0,0 @@
---- src/Ice-3.5.1/cpp/config/Make.rules 2013-10-04 17:48:15.000000000 +0200
-+++ Make.rules 2015-02-01 20:13:50.448211744 +0100
-@@ -11,13 +11,13 @@
- # Select an installation base directory. The directory will be created
- # if it does not exist.
- #
--prefix ?= /opt/Ice-$(VERSION)
-+prefix ?= /usr
-
- #
- # The "root directory" for runpath embedded in executables. Can be unset
- # to avoid adding a runpath to Ice executables.
- #
--embedded_runpath_prefix ?= /opt/Ice-$(VERSION_MAJOR).$(VERSION_MINOR)
-+#embedded_runpath_prefix ?= /opt/Ice-$(VERSION_MAJOR).$(VERSION_MINOR)
-
- #
- # Define create_runpath_symlink as yes if you would like 'make install'
-@@ -30,7 +30,7 @@
- # Define OPTIMIZE as yes if you want to build with
- # optimization. Otherwise Ice is build with debug information.
- #
--#OPTIMIZE = yes
-+OPTIMIZE = yes
-
- #
- # Define LP64 as yes or no if you want force a 32 or 64 bit. The
diff --git a/java8-compatibility.patch b/java8-compatibility.patch
deleted file mode 100644
index ce1b3581be64..000000000000
--- a/java8-compatibility.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-Description: Rename the MultiHashMap.remove() method to avoid a conflict
- with the new Map.remove(K, V) method introduced in Java 8
-Author: Emmanuel Bourg <ebourg@apache.org>
-Forwarded: no
-Bug-Debian: https://bugs.debian.org/745100
---- a/java/src/IceInternal/OutgoingConnectionFactory.java
-+++ b/java/src/IceInternal/OutgoingConnectionFactory.java
-@@ -29,7 +29,7 @@
- }
-
- public void
-- remove(K key, V value)
-+ removeKeyValue(K key, V value)
- {
- java.util.List<V> list = this.get(key);
- assert(list != null);
-@@ -622,9 +622,9 @@
- {
- for(Ice.ConnectionI c : cons)
- {
-- _connections.remove(c.connector(), c);
-- _connectionsByEndpoint.remove(c.endpoint(), c);
-- _connectionsByEndpoint.remove(c.endpoint().compress(true), c);
-+ _connections.removeKeyValue(c.connector(), c);
-+ _connectionsByEndpoint.removeKeyValue(c.endpoint(), c);
-+ _connectionsByEndpoint.removeKeyValue(c.endpoint().compress(true), c);
- }
- }
-
diff --git a/java_build.properties.patch b/java_build.properties.patch
deleted file mode 100644
index a277d34fa706..000000000000
--- a/java_build.properties.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- src/Ice-3.5.1/java/config/build.properties 2015-02-01 23:58:21.857968805 +0100
-+++ build.properties 2015-02-02 00:08:49.744624149 +0100
-@@ -20,9 +20,9 @@
- # to build the IceGrid GUI
- #
-
--jgoodies-common.version = 1.4.0
--jgoodies-forms.version = 1.6.0
--jgoodies-looks.version = 2.5.2
-+jgoodies-common.version = 1.8.0
-+jgoodies-forms.version = 1.8.0
-+jgoodies-looks.version = 2.6.0
-
- #
- # Select an installation base directory. The directory will be created
-@@ -67,3 +67,7 @@
- #jgoodies.common = /usr/share/java/jgoodies-common-${jgoodies-common.version}.jar
- #jgoodies.forms = /usr/share/java/jgoodies-forms-${jgoodies-forms.version}.jar
- #jgoodies.looks = /usr/share/java/jgoodies-looks-${jgoodies-looks.version}.jar
-+jgoodies.common = /usr/share/java/jgoodies-common/jgoodies-common-${jgoodies-common.version}.jar
-+jgoodies.forms = /usr/share/java/jgoodies-forms/jgoodies-forms-${jgoodies-forms.version}.jar
-+jgoodies.looks = /usr/share/java/jgoodies-looks/jgoodies-looks.jar
-+
diff --git a/php_Make.rules.php.patch b/php_Make.rules.php.patch
deleted file mode 100644
index 3bcb7f32d85f..000000000000
--- a/php_Make.rules.php.patch
+++ /dev/null
@@ -1,35 +0,0 @@
---- src/Ice-3.5.1/php/config/Make.rules.php 2013-10-04 17:48:15.000000000 +0200
-+++ Make.rules.php 2015-02-02 00:34:02.201263541 +0100
-@@ -12,20 +12,20 @@
- # if it does not exist.
- #
-
--prefix ?= /opt/Ice-$(VERSION)
-+prefix ?= /usr
-
- #
- # The "root directory" for runpath embedded in executables. Can be unset
- # to avoid adding a runpath to Ice executables.
- #
--embedded_runpath_prefix ?= /opt/Ice-$(VERSION_MAJOR).$(VERSION_MINOR)
-+#embedded_runpath_prefix ?= /opt/Ice-$(VERSION_MAJOR).$(VERSION_MINOR)
-
- #
- # Define OPTIMIZE as yes if you want to build with optimization.
- # Otherwise the Ice extension is built with debug information.
- #
-
--#OPTIMIZE = yes
-+OPTIMIZE = yes
-
- #
- # Define LP64 as yes if you want to build in 64 bit mode on a platform
-@@ -54,7 +54,7 @@
- # PHP_INCLUDE_DIR and PHP_LIB_DIR.
- #
-
--PHP_HOME ?= /opt/php
-+PHP_HOME ?= /usr
-
- #
- # Verifies the PHP_HOME is valid and attempts to adjust for platform variances
diff --git a/python2_Make.rules.patch b/python2_Make.rules.patch
deleted file mode 100644
index bce2080ce607..000000000000
--- a/python2_Make.rules.patch
+++ /dev/null
@@ -1,35 +0,0 @@
---- src/Ice-3.5.1/py/config/Make.rules 2013-10-04 17:48:15.000000000 +0200
-+++ Make.rules 2015-02-03 14:14:26.568180344 +0100
-@@ -12,20 +12,20 @@
- # if it does not exist.
- #
-
--prefix ?= /opt/Ice-$(VERSION)
-+prefix ?= /usr
-
- #
- # The "root directory" for runpath embedded in executables. Can be unset
- # to avoid adding a runpath to Ice executables.
- #
--embedded_runpath_prefix ?= /opt/Ice-$(VERSION_MAJOR).$(VERSION_MINOR)
-+#embedded_runpath_prefix ?= /opt/Ice-$(VERSION_MAJOR).$(VERSION_MINOR)
-
- #
- # Define OPTIMIZE as yes if you want to build with optimization.
- # Otherwise the Ice extension is built with debug information.
- #
-
--#OPTIMIZE = yes
-+OPTIMIZE = yes
-
- #
- # Define LP64 as yes if you want to build in 64 bit mode on a platform
-@@ -44,7 +44,7 @@
- # to a value like "python2.5". Otherwise, the settings below use the
- # default Python interpreter found in your PATH.
- #
--PYTHON_VERSION ?= python$(shell python -c "import sys; import distutils.sysconfig as ds; sys.stdout.write(ds.get_python_version())")
-+PYTHON_VERSION ?= python2.7
-
- PYTHON_BASE_VERSION ?= $(shell $(PYTHON_VERSION) -c "import sys; import distutils.sysconfig as ds; sys.stdout.write(ds.get_python_version())")
-
diff --git a/python3_Make.rules.patch b/python3_Make.rules.patch
deleted file mode 100644
index e8dc3c11906a..000000000000
--- a/python3_Make.rules.patch
+++ /dev/null
@@ -1,35 +0,0 @@
---- src/Ice-3.5.1/py/config/Make.rules 2013-10-04 17:48:15.000000000 +0200
-+++ Make.rules 2015-02-03 14:14:26.568180344 +0100
-@@ -12,20 +12,20 @@
- # if it does not exist.
- #
-
--prefix ?= /opt/Ice-$(VERSION)
-+prefix ?= /usr
-
- #
- # The "root directory" for runpath embedded in executables. Can be unset
- # to avoid adding a runpath to Ice executables.
- #
--embedded_runpath_prefix ?= /opt/Ice-$(VERSION_MAJOR).$(VERSION_MINOR)
-+#embedded_runpath_prefix ?= /opt/Ice-$(VERSION_MAJOR).$(VERSION_MINOR)
-
- #
- # Define OPTIMIZE as yes if you want to build with optimization.
- # Otherwise the Ice extension is built with debug information.
- #
-
--#OPTIMIZE = yes
-+OPTIMIZE = yes
-
- #
- # Define LP64 as yes if you want to build in 64 bit mode on a platform
-@@ -44,7 +44,7 @@
- # to a value like "python2.5". Otherwise, the settings below use the
- # default Python interpreter found in your PATH.
- #
--PYTHON_VERSION ?= python$(shell python -c "import sys; import distutils.sysconfig as ds; sys.stdout.write(ds.get_python_version())")
-+PYTHON_VERSION ?= python3.4
-
- PYTHON_BASE_VERSION ?= $(shell $(PYTHON_VERSION) -c "import sys; import distutils.sysconfig as ds; sys.stdout.write(ds.get_python_version())")
-