summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArisu2022-01-23 19:40:11 -0500
committerArisu2022-01-23 19:40:11 -0500
commitfaa8f5e94b1e5c172c046e0820673d8f10da67b2 (patch)
treebe8132498d6008fd311fa8b8aaa4df057b98bfa2
parent81a499ffe595cc5980865ce4627eb57f78b6dc9c (diff)
downloadaur-faa8f5e94b1e5c172c046e0820673d8f10da67b2.tar.gz
Ice for php 3.7.6 and fix module install dir
-rw-r--r--PKGBUILD12
-rw-r--r--redundant.patch21
2 files changed, 29 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 767e03ac5b57..5f7a5bef9541 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
-# Maintainer: Joe George <joe at externl dot com>
+# Maintainer: Arisu <arisuuwu32@gmail.com>
pkgname="zeroc-ice-php"
-pkgver=3.7.2
+pkgver=3.7.6
pkgrel=0
pkgdesc="PHP bindings for Ice RPC framework"
arch=("i686" "x86_64")
@@ -16,13 +16,17 @@ depends=("zeroc-ice=$pkgver" "php")
source=("ice-${pkgver}.tar.gz::https://github.com/zeroc-ice/ice/archive/v${pkgver}.tar.gz")
-sha256sums=('e329a24abf94a4772a58a0fe61af4e707743a272c854552eef3d7833099f40f9')
+sha256sums=('75b18697c0c74f363bd0b85943f15638736e859c26778337cbfe72d31f5cfb47')
make_args=(
"OPTIMIZE=yes"
"ICE_HOME=/usr/"
"ICE_BIN_DIST=cpp"
)
+prepare() {
+ cd ${srcdir}/ice-${pkgver}/
+ patch -p1 -i ../../redundant.patch
+}
build() {
cd ${srcdir}/ice-${pkgver}/php
@@ -33,7 +37,7 @@ build() {
package() {
cd ${srcdir}/ice-${pkgver}/php
- make install ${make_args[@]} DESTDIR="${pkgdir}" "install_phpdir=/usr/share/ice/php" "install_phplibdir=/usr/share/ice/php"
+ make install ${make_args[@]} DESTDIR="${pkgdir}" "install_phpdir=/usr/share/ice/php" "install_phplibdir=/usr/lib/php/modules"
msg "Installing Ice for PHP"
install -dm755 ${pkgdir}/etc/php/conf.d/
diff --git a/redundant.patch b/redundant.patch
new file mode 100644
index 000000000000..3f37ee4700d6
--- /dev/null
+++ b/redundant.patch
@@ -0,0 +1,21 @@
+From f542ad5eb07d9f129d7160d9e46ab07bda2afa7a Mon Sep 17 00:00:00 2001
+From: Jose <jose@zeroc.com>
+Date: Sat, 4 Dec 2021 09:54:36 +0100
+Subject: [PATCH] Ignore redundant declarations with PHP > 8
+
+---
+ php/src/php/Config.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/php/src/php/Config.h b/php/src/php/Config.h
+index c5d9db61d57..3f308d45ce7 100644
+--- a/php/src/php/Config.h
++++ b/php/src/php/Config.h
+@@ -50,6 +50,7 @@ extern "C"
+
+ #if defined(__GNUC__) && ((__GNUC__ >= 8))
+ # pragma GCC diagnostic ignored "-Wignored-qualifiers"
++# pragma GCC diagnostic ignored "-Wredundant-decls"
+ #endif
+
+ //