summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredfish2019-03-28 22:33:39 -0400
committerredfish2019-03-28 22:33:39 -0400
commit0ce5e9b27c7db8cabc3f67f336e8364f989610d2 (patch)
tree436722084fcbf999152c18c6243b4cbe4f4d7654
parent559149dd0e11845a351e6445035dba56bf4c68a7 (diff)
downloadaur-0ce5e9b27c7db8cabc3f67f336e8364f989610d2.tar.gz
python 3 branch
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD12
-rw-r--r--zeronet.service2
3 files changed, 28 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a40d27e4c40..05d639594af3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,40 @@
# Generated by mksrcinfo v8
-# Mon Feb 18 01:37:10 UTC 2019
+# Fri Mar 29 02:33:20 UTC 2019
pkgbase = zeronet-git
pkgdesc = Decentralized websites using Bitcoin crypto and the BitTorrent network.
- pkgver = 0.6.5
+ pkgver = 0.7.0.r4033.g5df8e10b
pkgrel = 1
url = https://zeronet.io/
install = zeronet.install
arch = any
license = GPL2
makedepends = git
- depends = python2
- depends = python2-gevent
- depends = python2-msgpack
+ depends = python
+ depends = python-gevent>=1.1.0
+ depends = python-gevent-websocket
+ depends = python-msgpack>=0.4.4
+ depends = python-websocket-client
+ depends = python-rsa
+ depends = python-pysocks
+ depends = python-pyasn1
+ depends = python-base58
+ depends = python-pyelliptic
+ depends = python-merkletools
+ depends = python-bencode.py
+ depends = python-coincurve
+ depends = python-bitcoinlib
+ depends = python-maxminddb
optdepends = tor: anonymity
provides = zeronet
conflicts = zeronet
options = !strip
backup = etc/zeronet.conf
- source = git+https://github.com/HelloZeroNet/ZeroNet.git
+ source = git+https://github.com/HelloZeroNet/ZeroNet.git#branch=py3
source = zeronet.conf
source = zeronet.service
sha256sums = SKIP
sha256sums = ea735e82dbb10a2c1fda7abfeb2f38c2429044d8254f9e2396c50cecb6f778f8
- sha256sums = 22dfda6233d0477a63247ae3ebb2ccd0b8a181f1628bd2969a9f979f0b9e7ca8
+ sha256sums = 2ee64a1b671a49a1626901a11d4d7fa338c77cb9b7c9facd2f56b087a4a0bb83
pkgname = zeronet-git
diff --git a/PKGBUILD b/PKGBUILD
index 8cb4c18353fa..79cba17ccd65 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,18 +4,22 @@
pkgname='zeronet-git'
_gitname='ZeroNet'
_gitroot='https://github.com/HelloZeroNet/ZeroNet.git'
-pkgver=0.6.5
+pkgver=0.7.0.r4033.g5df8e10b
pkgrel=1
arch=('any')
url="https://zeronet.io/"
-depends=('python2' 'python2-gevent' 'python2-msgpack')
+depends=('python' 'python-gevent>=1.1.0' 'python-gevent-websocket'
+ 'python-msgpack>=0.4.4' 'python-websocket-client' 'python-rsa'
+ 'python-pysocks' 'python-pyasn1' 'python-base58' 'python-pyelliptic'
+ 'python-merkletools' 'python-bencode.py' 'python-coincurve'
+ 'python-bitcoinlib' 'python-maxminddb')
optdepends=('tor: anonymity')
makedepends=('git')
license=('GPL2')
pkgdesc="Decentralized websites using Bitcoin crypto and the BitTorrent network."
provides=(zeronet)
conflicts=(zeronet)
-source=("git+https://github.com/HelloZeroNet/ZeroNet.git"
+source=("git+https://github.com/HelloZeroNet/ZeroNet.git#branch=py3"
"zeronet.conf"
"zeronet.service")
install="zeronet.install"
@@ -45,4 +49,4 @@ package() {
}
sha256sums=('SKIP'
'ea735e82dbb10a2c1fda7abfeb2f38c2429044d8254f9e2396c50cecb6f778f8'
- '22dfda6233d0477a63247ae3ebb2ccd0b8a181f1628bd2969a9f979f0b9e7ca8')
+ '2ee64a1b671a49a1626901a11d4d7fa338c77cb9b7c9facd2f56b087a4a0bb83')
diff --git a/zeronet.service b/zeronet.service
index e8c51642e51a..e79de2ed0449 100644
--- a/zeronet.service
+++ b/zeronet.service
@@ -5,7 +5,7 @@ Description=ZeroNet: a decentralized web platform
User=zeronet
Group=zeronet
WorkingDirectory=/opt/zeronet
-ExecStart=/usr/bin/env python2 zeronet.py --config_file /etc/zeronet.conf
+ExecStart=/usr/bin/env python zeronet.py --config_file /etc/zeronet.conf
SyslogIdentifier=zeronet
Restart=on-failure