summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredfish2017-10-18 00:48:49 -0400
committerredfish2017-10-18 00:49:48 -0400
commited2efa33a11e426698b769a019b4113616140dcc (patch)
tree047c953aaf0de9581cadf9ce1876bf0a9a25f393
parented1dd477fc5df0663de004290300331de1b6fe37 (diff)
downloadaur-ed2efa33a11e426698b769a019b4113616140dcc.tar.gz
tor bug 19953 was fixed, no need for tor-auth
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD2
-rw-r--r--zeronet.install10
3 files changed, 11 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f430754a47ac..2dfb81a04b31 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sun Aug 20 05:29:58 UTC 2017
+# Wed Oct 18 04:49:09 UTC 2017
pkgbase = zeronet-git
pkgdesc = Decentralized websites using Bitcoin crypto and the BitTorrent network.
pkgver = 0.5.7
@@ -12,7 +12,7 @@ pkgbase = zeronet-git
depends = python2>=2.7.10
depends = python2-gevent
depends = python2-msgpack
- optdepends = tor>=0.2.7.6: anonymity
+ optdepends = tor>=0.3.0.0: anonymity
provides = zeronet
conflicts = zeronet
options = !strip
diff --git a/PKGBUILD b/PKGBUILD
index 288d7841a5b4..701b40cb7078 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@ depends=('python2>=2.7.10'
'python2-gevent'
'python2-msgpack'
)
-optdepends=('tor>=0.2.7.6: anonymity')
+optdepends=('tor>=0.3.0.0: anonymity')
makedepends=('git')
license=('GPL2')
pkgdesc="Decentralized websites using Bitcoin crypto and the BitTorrent network."
diff --git a/zeronet.install b/zeronet.install
index 5c2b09b74eb9..1be4583187fc 100644
--- a/zeronet.install
+++ b/zeronet.install
@@ -8,11 +8,11 @@ post_install() {
# Don't run thesre operations automatically, because they are security-sensitive
echo ">>> Default mode is clearnet+Tor. Give zeronet permissions to configure hidden service:"
echo ">>> sudo usermod -a -G tor zeronet"
- echo ">>> sudo mkdir -m 750 /var/lib/tor-auth && sudo chown tor:tor /var/lib/tor-auth"
echo ">>> Add/edit the following options in /etc/tor/torrc:"
+ echo ">>> DataDirectoryGroupReadable 1"
echo ">>> CookieAuthentication 1"
echo ">>> CookieAuthFileGroupReadable 1"
- echo ">>> CookieAuthFile /var/lib/tor-auth/control_auth_cookie"
+ echo ">>> CookieAuthFile /var/lib/tor/control_auth_cookie"
echo ">>> Restart tor (reload not enough):"
echo ">>> sudo systemctl restart tor"
echo ">>> Run daemon and check status and view log:"
@@ -31,4 +31,10 @@ post_install() {
post_upgrade() {
chown -R zeronet:zeronet /opt/zeronet
+
+ echo ">>> UPDATE in 0.6.0: no longer need auth dir (Tor bug 19953 fixed):"
+ echo ">>> Change or add to /etc/tor/torrc:"
+ echo ">>> DataDirectoryGroupReadable 1"
+ echo ">>> CookieAuthFile /var/lib/tor/control_auth_cookie"
+ echo ">>> Run: sudo rm -r /var/lib/tor-auth && sudo systemctl restart tor"
}