summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Rogoża2015-06-14 15:50:53 +0200
committerPiotr Rogoża2015-06-14 15:50:53 +0200
commit7d59c667f208750bf7887694c6f842b5eaba927e (patch)
treeaa87d57fa585832ae43dc18fb8cb04e8702825b1
downloadaur-7d59c667f208750bf7887694c6f842b5eaba927e.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD58
-rw-r--r--zeronoise.desktop10
-rw-r--r--zeronoise.install17
-rw-r--r--zeronoise_64x64.pngbin0 -> 6959 bytes
5 files changed, 108 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..da4d4f3fce95
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = zeronoise
+ pkgdesc = HDR, get tiff from several shots without noise and a lot of dynamic range
+ pkgver = 1.04.4
+ pkgrel = 1
+ url = http://www.guillermoluijk.com/tutorial/zeronoise/index.htm
+ install = zeronoise.install
+ arch = i686
+ arch = x86_64
+ license = custom:freeware
+ depends = hicolor-icon-theme
+ depends = wxgtk
+ depends = gsl
+ depends = libpng12
+ depends = libtiff
+ options = !strip
+ source = https://sites.google.com/site/zeronoiselinux/file-cabinet/zeronoise-1.04.4_.deb
+ source = zeronoise.desktop
+ source = zeronoise_64x64.png
+ md5sums = 8244f0d3f656b329ea744f6a4bdc1b57
+ md5sums = 45396c7b617e1d7cdb65303a24255e7f
+
+pkgname = zeronoise
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..162ac7c69319
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Piotr Rogoża <rogoza dot piotr at gmail dot com>
+# Contributor: Piotr Rogoża <rogoza dot piotr at gmail dot com>
+# vim:set ts=2 sw=2 et ft=sh tw=100: expandtab
+
+pkgname=zeronoise
+pkgver=1.04.4
+pkgrel=1
+pkgdesc='HDR, get tiff from several shots without noise and a lot of dynamic range'
+arch=('i686' 'x86_64')
+url='http://www.guillermoluijk.com/tutorial/zeronoise/index.htm'
+license=('custom:freeware')
+groups=()
+depends=(hicolor-icon-theme wxgtk gsl libpng12 libtiff)
+makedepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!strip)
+install='zeronoise.install'
+#CARCH=x86_64
+case $CARCH in
+ i686)
+ _CARCH=i386
+ md5sums=('9b10507a8432d3056bc70f8d34990e86')
+ ;;
+ x86_64)
+ _CARCH=amd64
+ md5sums=('a413a3609a0ed94582856e7b5f7fc58e')
+ ;;
+esac
+source=(https://sites.google.com/site/zeronoiselinux/file-cabinet/$pkgname-${pkgver}_${_CARCH}.deb
+zeronoise.desktop
+zeronoise_64x64.png
+)
+noextract=()
+
+package(){
+ cd "$srcdir"
+ tar zxf data.tar.gz
+ install -Dm755 usr/local/bin/zeronoise "$pkgdir"/usr/bin/zeronoise
+ install -dm755 "$pkgdir"/usr/share/zeronoise
+ install -Dm644 usr/share/zeronoise/default2.png "$pkgdir"/usr/share/zeronoise/
+ install -Dm644 usr/share/zeronoise/default.png "$pkgdir"/usr/share/zeronoise/
+ install -Dm644 "$srcdir"/zeronoise.desktop "$pkgdir"/usr/share/applications/zeronoise.desktop
+ install -Dm644 "$srcdir"/zeronoise_64x64.png "$pkgdir"/usr/share/icons/hicolor/64x64/apps/zeronoise.png
+ #
+ install -dm755 "$pkgdir"/usr/share/licenses/zeronoise
+
+# workaround to missing libtiff.so.4
+ install -dm755 "$pkgdir"/usr/lib
+ cd "$pkgdir"/usr/lib
+ ln -s libtiff.so libtiff.so.4
+}
+md5sums+=(
+ '8244f0d3f656b329ea744f6a4bdc1b57'
+ '45396c7b617e1d7cdb65303a24255e7f')
diff --git a/zeronoise.desktop b/zeronoise.desktop
new file mode 100644
index 000000000000..7a8a9c687cb0
--- /dev/null
+++ b/zeronoise.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Type=Application
+Name=Zeronoise
+Comment=HDR, get tiff from several shots without noise and a lot of dynamic range
+Exec=zeronoise
+Icon=zeronoise
+Terminal=false
+StartupNotify=false
+Categories=Application;Graphics;Photography;
diff --git a/zeronoise.install b/zeronoise.install
new file mode 100644
index 000000000000..7975721447fc
--- /dev/null
+++ b/zeronoise.install
@@ -0,0 +1,17 @@
+post_install() {
+ if which update-desktop-database &>/dev/null; then
+ update-desktop-database -q usr/share/applications
+ fi
+ if which gtk-update-icon-cache &>/dev/null; then
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ fi
+}
+
+post_upgrade() {
+ post_install $
+}
+
+post_remove() {
+ post_install $
+}
+
diff --git a/zeronoise_64x64.png b/zeronoise_64x64.png
new file mode 100644
index 000000000000..436a4efdd36c
--- /dev/null
+++ b/zeronoise_64x64.png
Binary files differ